Ads keep us online. Without them, we wouldn't exist. We don't have paywalls or sell mods - we never will. But every month we have large bills and running ads is our only way to cover them. Please consider unblocking us. Thank you from GameBanana <3

Sonic '06 Mod Manager - A Modding Tool for Sonic the Hedgehog (2006).

A tool to handle mod copying and organisation for Sonic '06

A tool designed to make it easier to use and manage mods for Sonic '06 on the Xbox 360 and PlayStation 3.

For detailed documentation, see the Sonic '06 Mod Manager wiki on GitHub: https://github.com/Big-Endian-32/Sonic-06-Mod-Manager/wiki

If the game is missing sounds and visual effects, then ensure that you FULLY extracted your ISO (See here for instructions on that)
If certain patches cause an error upon installation, then ensure that you have Java installed (a system restart may be required), this is caused by certain patches using a Java script to decompile the game's Lua Bytecode for editing.
1-10 of 51
1
Pages
Go to page:
  • Blu Hedgie avatar
    Blu Hedgie Joined 5y ago
    Offline
    279 points Ranked 74,080th
    1mo 1mo
    I'm not sure what to do, but every tutorial I have watched just has a sonic 2006 iso file. I only have the raw files taken directly from my xbox 360. The file xenia recognizes is  "F38850A654331F57DB09B6F07709C3E8" I tried renaming it to default.xex, but then xenia can't read that file and the mod manager won't recognize it either. What do I need to do to get the mod manager to recognize my file?

    I've also tried sonic 06 tool kit and marathon, but the 06 tool kit crashes and marathon just closes the command line. Velocity was also no help either.

    Never mind I found a video that does exactly what I need.

    Bananite
    URL to post:
  • Aire de forces avatar
    Aire de forces Joined 1y ago
    Offline
    215 points Ranked 82,919th
    2mo
    I don't know why he does this to me ?
    Bananite
    URL to post:
  • DarkStarBowser avatar
    DarkStarBowser Joined 1y ago
    Offline
    661 points Ranked 53,416th
    5 medals 1 rare
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    4mo
    Everytime i try to install the content i get this error, how do i fix it?
    Bananite
    URL to post:
  • Hexs avatar
    Hexs Joined 4mo ago
    Offline
    4mo
    hello! I'm trying to set up a Steam shortcut that when pressing "Launch" in Steam will run Sonic 06 on Xenia through this mod manager but I can't seem to figure out how.

    I can directly launch modded Sonic Heroes through the Reloaded II mod manager by adding Reloaded II as a non-Steam game an adding "--launch [file path to Sonic Heroes.exe]" to the shortcut's target setting in Steam. Does this mod loader have this or similar functionality? I can add the Sonic 06 Mod Manager as a non-Steam game but then I need to awkwardly press the launch button in the mod manager for the game to actually start. Is there a launch argument I can add that will automatically run the game when the mod manager is launched? I've tried the same argument as Reloaded II but that hasn't worked. I've also looked through all the documentation on GitHub for this mod loader and haven't found anything.

    Also, an option to automatically close the mod manager when xenia closes would be nice as well.
    relax, enjoy
    URL to post:
  • 5mo 5mo
    For some reason, the only thing after the title menu is a character select and then I always end up in a short version of Kingdom Valley.
    I´m really new to this emulating and mod stuff so I have no idea what to do.
    Bananite
    URL to post:
  • JonyPlayz avatar
    JonyPlayz Joined 2y ago
    Offline
    975 points Ranked 47,666th
    10 medals 1 legendary 1 rare
    • Returned 5000 times Medal icon
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • Thanked 5 submitters Medal icon
    6mo

    It says this when i launch it
    Bananite
    URL to post:
  • GreatGuy4567 avatar
    GreatGuy4567 Joined 6mo ago
    Offline
    192 points Ranked 86,421st
    6mo
    my previous error got fixed but how to fix this error 
    System.IO.InvalidDataException: Found invalid data while decoding.

       at System.IO.Compression.InflaterZlib.Inflate(FlushCode flushCode)

       at System.IO.Compression.InflaterZlib.ReadInflateOutput(Byte[] outputBuffer, Int32 offset, Int32 length, FlushCode flushCode, Int32& bytesRead)

       at System.IO.Compression.InflaterZlib.Inflate(Byte[] bytes, Int32 offset, Int32 length)

       at System.IO.Compression.DeflateStream.Read(Byte[] array, Int32 offset, Int32 count)

       at Marathon.IO.Helpers.ZlibStream.Read(Byte[] buffer, Int32 offset, Int32 count)

       at System.IO.Stream.InternalCopyTo(Stream destination, Int32 bufferSize)

       at System.IO.Stream.CopyTo(Stream destination)

       at Marathon.IO.Formats.Archives.U8Archive.U8ArchiveFile.Decompress(Stream stream, ArchiveFile file)

       at Marathon.IO.Formats.Archives.U8Archive.<Load>g__ParseEntries|9_0(UInt32 u8EntryIndex, ArchiveDirectory entries, Boolean isRoot, <>c__DisplayClass9_0& )

       at Marathon.IO.Formats.Archives.U8Archive.<Load>g__ParseEntries|9_0(UInt32 u8EntryIndex, ArchiveDirectory entries, Boolean isRoot, <>c__DisplayClass9_0& )

       at Marathon.IO.Formats.Archives.U8Archive.<Load>g__ParseEntries|9_0(UInt32 u8EntryIndex, ArchiveDirectory entries, Boolean isRoot, <>c__DisplayClass9_0& )

       at Marathon.IO.Formats.Archives.U8Archive.<Load>g__ParseEntries|9_0(UInt32 u8EntryIndex, ArchiveDirectory entries, Boolean isRoot, <>c__DisplayClass9_0& )

       at Marathon.IO.Formats.Archives.U8Archive.<Load>g__ParseEntries|9_0(UInt32 u8EntryIndex, ArchiveDirectory entries, Boolean isRoot, <>c__DisplayClass9_0& )

       at Marathon.IO.Formats.Archives.U8Archive.Load(Stream stream)

       at Marathon.IO.FileBase.Load(String file)

       at Unify.Patcher.ModEngine.UnpackARC(String arc, String extractDir)

       at Unify.Patcher.ModEngine.Merge(String arc1, String arc2)

       at Unify.Patcher.ModEngine.InstallMods(String mod, String name)

       at Unify.Environment3.RushInterface.InstallThread(Boolean mods, Boolean patches)

    Bananite
    URL to post:
  • GreatGuy4567 avatar
    GreatGuy4567 Joined 6mo ago
    Offline
    192 points Ranked 86,421st
    6mo
    can someone help me when i select a mod and click save and install content the mod unchecks by itself
    and dosent install this dosent happpen with patches though
    Bananite
    URL to post:
  • T-S avatar
    T-S Joined 6mo ago
    Offline
    6mo
    Hello currently I may have followed the steps, checked certain patches and put mods, to have pressed save, install and launch.
    
    The game may be launched in the sonic manager unfortunately it remains in vanilla.
    
    I have tried some solutions but the result remains the same.

    Bananite
    URL to post:
  • dogfins110 avatar
    dogfins110 Joined 7mo ago
    Offline
    6mo
    I can’t launch the game through mod manager because it’s an iso. It launches perfectly on emulator but I can’t get the mod manager to detect the iso be of its file type. 

    what do I do?
    Bananite
    URL to post: