HL2.exe has stopped working

A Forum Thread for Counter-Strike: Source

SEX! Ok, we got your attention. We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending Lucedis points.
  • Post: Give Lucedis your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Stop Lurking!

Sign up

Already a Bananite? Login

Help me. )=

For some reason, Counter-strike Source just won't work. I haven't played in about, 4 weeks, because i just don't have the time these days to play games. But today I do, but CS:S will not work. When I start Counter-strike Source, I get this window after about 5 seconds after the 'Preparing to launch Counter-Strike Source..' window. btw, I'm running on Vista. I never got this error before. I've tried to re-install Counter-Strike Source 3 times. I've tried uninstalling from the control panel. I've tried uninstalling by deleting local content. I've tried restarting my computer. I've googled 'hl2.exe has stopped working'. But I haven't found a solution to my problem. I am sorry if this has been posted. I've searched on FPSBanana for a thread like this one. But the threads I've looked at never seemed to have a solution. Sorry again if this has been posted. Thanks in advance, uNeek.

Posts

  • 10y
    KaT_FisH avatar
    KaT_FisH Offline
    Member Joined 11y
    37,686 points Ranked 106th
    What OS is that?
    <3 <3 <3 avatar
    Mantra
    <3 <3 <3
  • 10y
    Lucedis avatar
    Lucedis Offline
    Member Joined 12y
    4,719 points Ranked 981st
    I'm running on Vista.
    i pity the noob!
  • 10y
    JtMax avatar
    JtMax Offline
    Member Joined 12y
    Vista.
    Remember to thumb up good post avatar
    Mantra
    Remember to thumb up good post
  • 10y
    Scouts avatar
    Scouts Offline
    Member Joined 11y
    2,044 points Ranked 2312th
    9 medals 1 rare
    • 6 years a member Medal icon
    • Became a Club Leader Medal icon
    • Reached 1,000 Points Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    Scouts Cooking Expert
    Posted by uNeek

    I'm running on Vista.


    Windows 95.
    Bane Of The Banana avatar
    Mantra
    Bane Of The Banana
  • 10y
    blueguile avatar
    blueguile Offline
    Member Joined 12y
    37,440 points Ranked 107th
    13 medals 1 legendary 1 rare
    • 10 years a member Medal icon
    • 6 years a member Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • Reached 25,000 Points Medal icon
    Posted by Scouts

    Posted by uNeek

    I'm running on Vista.


    Windows 95.
    lol right?
    Who needs Alienware, I build m avatar
    Mantra
    Who needs Alienware, I build m
  • 10y
    KaT_FisH avatar
    KaT_FisH Offline
    Member Joined 11y
    37,686 points Ranked 106th
    I have no idea how to pinpoint the problem in vista really...
    Are the ports for steam and CS:S forwarded correctly?
    Do you have any viruses?
    Do you have a program blocker? Like an anti-virus program or firewall?

    The best thing to do really is format your hard drive.
    <3 <3 <3 avatar
    Mantra
    <3 <3 <3
  • 10y
    Lucedis avatar
    Lucedis Offline
    Member Joined 12y
    4,719 points Ranked 981st
    Posted by kat_fish

    Are the ports for steam and CS:S forwarded correctly?
    Do you have any viruses?
    Do you have a program blocker? Like an anti-virus program or firewall?

    The best thing to do really is format your hard drive.


    1. Yes
    2. Yes
    3. No

    And I'm not willing to format.

    Any other ideas, guys?
    i pity the noob!
  • 10y
    KaT_FisH avatar
    KaT_FisH Offline
    Member Joined 11y
    37,686 points Ranked 106th
    Posted by uNeek

    Posted by kat_fish

    Are the ports for steam and CS:S forwarded correctly?
    Do you have any viruses?
    Do you have a program blocker? Like an anti-virus program or firewall?

    The best thing to do really is format your hard drive.


    1. Yes
    2. Yes
    3. No

    And I'm not willing to format.

    Any other ideas, guys?


    Get rid of the viruses.
    <3 <3 <3 avatar
    Mantra
    <3 <3 <3
  • 10y
    Lucedis avatar
    Lucedis Offline
    Member Joined 12y
    4,719 points Ranked 981st
    Oh woops. I mean no, I don't have any viruses xD
    i pity the noob!
  • 10y
    Lucedis avatar
    Lucedis Offline
    Member Joined 12y
    4,719 points Ranked 981st
    Anyone? Please.
    i pity the noob!
  • 10y
    boriska808 avatar
    boriska808 Offline
    Member Joined 11y
    1,082 points Ranked 4357th
    Meaby its beacuse your Windowz meaby you have a vista'z
    ^,,.^ avatar
    Mantra
    ^,,.^
  • 10y
    KniteWulf avatar
    KniteWulf avatar SYSTEMS OFFLINE
    Member Joined 11y
    11 medals 1 legendary 1 rare
    • 10 years a member Medal icon
    • 6 years a member Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • 5 posts awarded Exemplary Feedback Medal icon
    • 10 posts awarded Exemplary Feedback Medal icon
    • One month a member Medal icon
    Vista runs HL2.exe like crap. I hated playing CSS on Vista, as well as anything else. I'd recommend going to back to XP until a new SP comes out for Vista.
    Chief of Nostalgia avatar
    Mantra
    Chief of Nostalgia
  • 10y
    Lucedis avatar
    Lucedis Offline
    Member Joined 12y
    4,719 points Ranked 981st
    Posted by KniteWulf

    Vista runs HL2.exe like crap. I hated playing CSS on Vista, as well as anything else. I'd recommend going to back to XP until a new SP comes out for Vista.


    CS:S ran fine on Vista for me. But now I can't play because this error.
    i pity the noob!
  • 10y
    Rage142 avatar
    Rage142 Offline
    Member Joined 10y
    Im having the same problem it ran fine even great but now it just keeps craping out
    Bananite
  • 10y
    Jake. avatar
    Jake. Offline
    Member Joined 10y
    748 points Ranked 6171st
    Posted by boriska808

    Meaby its beacuse your Windowz meaby you have a vista'z

    Bull shit. Me and my friend both use Vista, and it works fine. Although that could be because we both spent a whole day hacking it to get it run OK

    Are the ports for steam and CS:S forwarded correctly?

    Makes no difference... I don't have port forwarding enabled AT ALL and it works fine for me
  • 10y
    Rage142 avatar
    Rage142 Offline
    Member Joined 10y
    To resolve this issue, please login to your machine as an administrator and open a command prompt.

    Type in the following:

    net localgroup Administrators /add Local Service
    this works do this and it should work fine
    Bananite
  • 10y
    Massive. avatar
    Massive. Offline
    Member Joined 10y
    10,135 points Ranked 429th
    I have that problem alot.
    Not for hl2.exe (*edit had it 5 times) but with other programs like Opera, Windows Live Messenger and Media Player I have it constantly, very frustrating.

    And I have it always when I close hammer.

    hammer.exe doesn't work anymore
    there's a problem blabla ...

    some of my errors i lold
    make me sandwich
  • 10y
    Zabuza avatar
    Zabuza Offline
    Member Joined 11y
    17,947 points Ranked 241st
    10 medals 1 legendary 1 rare
    • 10 years a member Medal icon
    • 6 years a member Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • One month a member Medal icon
    Just use the compatibility modus and set it to XP Pro.
    Mantra
    "The instrument of Doom"
  • 10y
    Lucedis avatar
    Lucedis Offline
    Member Joined 12y
    4,719 points Ranked 981st
    Posted by Rage142

    To resolve this issue, please login to your machine as an administrator and open a command prompt.

    Type in the following:

    net localgroup Administrators /add Local Service
    this works do this and it should work fine


    Yeah. What he said. I found that command prompt after minutes of searching the IGN forums.
    i pity the noob!
  • 10y
    iAndri avatar
    iAndri Offline
    Member Joined 10y
    Oh boy! I registered just so I could express my thanks! That command thing worked! <3
    Bananite
  • 10y
    Well that doesnt work for me do u know y?
    Bananite
  • 7y
    TheVotolom avatar
    TheVotolom Offline
    Member Joined 7y
    i know this is a rly rly old post, but if it hasnt worked yet try deleting the h2l.exe then run a VGC then launch it, that worked for me
    In bed...
  • 7y
    peepin avatar
    peepin Offline
    Member Joined 10y
    1,071 points Ranked 4403rd
    8 medals 1 rare
    • 6 years a member Medal icon
    • Reached 1,000 Points Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    @TheVotolom: Dude this is 3 years OLD.. How do you find topics this old in the 1st place >.>
    Pinapplezz avatar
    Mantra
    Pinapplezz
  • 7y
    sKratch avatar
    sKratch Offline
    Member Joined 10y
    23,828 points Ranked 181st
    10 medals 1 rare
    • 6 years a member Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • One month a member Medal icon
    Well... Someone has already bumped this so I'll just ask for the heck of it.
    How do I stop hammer from crashing all the time?
    I'm using Windows 7 (64-Bits), should I run it in competability mode or something..? :P
    Fuck. avatar
    Mantra
    Fuck.

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

Lucedis avatar
Lucedis Offline
Member Joined 12y
4,719 points Ranked 981st

Lucedis
Sign up to access this!
Sign up to access this!
Sign up to access this!
Sign up to access this!

Category

Stats

Posts
24
Views
26,286
Date Added
10y
Date Modified
10y
bcp.crwdcntrl.net tracking pixel