Demo Crash

Greetings! We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending The_Walking_Ghost points.
  • Post: Give The_Walking_Ghost your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Stop Lurking!

Sign up

Already a Bananite? Login

Hi every time i try to play the demo the game crash. when the bioshock sign fades away after you are in the plane the screen just go black and then when i push ctrl+alt+del it says that bioshock.exe is not working. my specs are Intel core 2 duo e6600 Asus geforce 8800gts 640mb 2gb ram windows vista premium hope that there is a fix for it

Posts

  • 10y
    SaberTooth avatar
    SaberTooth Offline
    Member Joined 10y
    Maybe wait some minutes and then it will run?
    Go to hell and say hello to sa avatar
    Mantra
    Go to hell and say hello to sa
  • 10y
    Enraged avatar
    Enraged Offline
    Member Joined 10y
    2,687 points Ranked 1710th
    I have the same processor and ram as you. However I have the full version I bought at game, and my one runs like a dream. I heard some people were having problems running the demo with geforce graphics cards however, so I am going to blame that.
    All Your Base Are Belong To Us avatar
    Mantra
    All Your Base Are Belong To Us
  • 10y
    Eraser avatar
    Eraser Offline
    Member Joined 13y
    4,410 points Ranked 1034th
    Apparently it's not doing so great in Vista.. so i'd put that down to it.
    MY AVATAR IS IRRELEVANT AGAIN!
  • 10y
    markslo1 avatar
    markslo1 Offline
    Member Joined 11y
    1,787 points Ranked 2628th
    I would preffer you to install XP, until Vista gets all the needed stuff.
    OPEN UP YOUR HEARTS PEOPLE! avatar
    Mantra
    OPEN UP YOUR HEARTS PEOPLE!
  • 10y
    The_Walking_Ghost avatar
    Member Joined 10y
    883 points Ranked 5237th
    Got it to work
    just installed the latest driver, not the beta driver but the forceware 162.22

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

The_Walking_Ghost avatar
Member Joined 10y
883 points Ranked 5237th

The_Walking_Ghost
Send a Private Message to the submitter

Game

Category

Stats

Posts
5
Views
1,608
Date Added
10y
bcp.crwdcntrl.net tracking pixel