Bioshock Demo Problems

A Forum Thread for BioShock

Yo, buddy. We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending W1LLDAB3AST points.
  • Post: Give W1LLDAB3AST your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Resistance is futile...

Sign up

Already a Bananite? Login

I just downloaded the Bioshock demo from steam. When I run it, a tiny rectangle that says Bioshock appears in the middle of the screen. After that the screen goes black and stays that way. I'm running an nVidia Geforce 8800 Ultra and Vista. Have any of you had the same problems? Do I need new drivers or what?

Posts

  • 10y
    I played it on a 7600 GT on XP Home and it worked fine. I had everything on high as well. Let me tell you that is going to be on weird ass game.
    From the Shade I Shall Strike avatar
    Mantra
    From the Shade I Shall Strike
  • 10y
    W1LLDAB3AST avatar
    Member Joined 10y
    26,371 points Ranked 162nd
    Vista is a piece of shit! I hate it, nothing works.
    a.k.a. WilliamBrutality
  • 10y
    sssnake avatar
    sssnake Offline
    Member Joined 11y
    35,048 points Ranked 118th
    I doubt you'll get any help this soon since it recently came out. Try to update the drivers. Also, Bioshock is an extremely performance-needy game. Can we have your system specifications?
    I TURN MAH PC TO DA SIDE avatar
    Mantra
    I TURN MAH PC TO DA SIDE
  • 10y
    W1LLDAB3AST avatar
    Member Joined 10y
    26,371 points Ranked 162nd
    Posted by sssnake

    I doubt you'll get any help this soon since it recently came out. Try to update the drivers. Also, Bioshock is an extremely performance-needy game. Can we have your system specifications?

    Intel Core2 Q6600 2.4GHz, 2GB DDR2 SDRAM, 768MB nVidia GeForce 8800 Ultra, Windows Shitsta I mean Vista.
    a.k.a. WilliamBrutality
  • 10y
    S.T.A.R.S Punisher avatar
    Member Joined 12y
    252 points Ranked 15306th
    WTF are you on? Windows Vista owns, you guys just don't know how to do anything with it 0_o

    Am I the only one who hasn't had one problem with it?
    Blaarrg.
  • 10y
    Cook1eMan avatar
    Cook1eMan Offline
    Member Joined 10y
    Vista is not shit, steam is! Im running the demo on Vista Ultimate, AMD 4200x2 dual core 2.2Ghz, 1Gb of Ram, and a XFX 8600GT XXX Edition. Everything works fine for me.

    Did you update your video drivers to the latest version?

    They released a new version thats required for bioshock to run.
    Does it matter? avatar
    Mantra
    Does it matter?
  • 10y
    W1LLDAB3AST avatar
    Member Joined 10y
    26,371 points Ranked 162nd
    Posted by Cook1eMan

    Vista is not shit, steam is! Im running the demo on Vista Ultimate, AMD 4200x2 dual core 2.2Ghz, 1Gb of Ram, and a XFX 8600GT XXX Edition. Everything works fine for me.

    Did you update your video drivers to the latest version?

    They released a new version thats required for bioshock to run.

    Well, that there's your problem.
    a.k.a. WilliamBrutality
  • 10y
    jacko87 avatar
    jacko87 Offline
    Member Joined 11y
    252 points Ranked 15306th
    Hmmm...is that for the 8600 too? Because I'm having the same problem. I'm on a laptop though and don't know if I can get drivers for it.
    Bananite

Embed

Share banner
Image URL:
HTML embed code:
BB embed code:
Markdown embed code:

Submitter

W1LLDAB3AST avatar
Member Joined 10y
26,371 points Ranked 162nd

W1LLDAB3AST
Sign up to access this!
Sign up to access this!
Sign up to access this!

Game

Sign up to access this!

Category

Stats

Posts
8
Views
2,651
Date Added
10y
Date Modified
10y
bcp.crwdcntrl.net tracking pixel