Decompressing a Zelda 64 Rom?

A Forum Thread for The Legend of Zelda: Ocarina of Time

Members see zero ads. Signup for free
I want to make a mod on a 1.0 U Rom version, I need to extract the rom in order to edit the game, I tried with the only tool I have found around the Internet, a very basic command prompt extractor called "zdec", you would only need to create a RUN.bat file with the command zdec "name of rom to extract" "name of extracted rom" and zdec.exe should do the rest. Here is where my problems start.

As it is a .bat file CMD should be opening, but I have Windows 10 which forces Powershell instead, so any time I want to run CMD it's going to close no matter what. I tried some methods to revert to CMD, but it doesn't seems to have any effect at the end. I surrendered to Powershell, so I changed the file extension to .ps1 in order to open it from Powershell, it shows a red text message that I can't read because it closes in 1 frame (I tried recording it but its just too fast so I can't read it well enough) my guess is that the executable won't ever look for a .ps1 instead of a .bat file so it will never understand "zdec" as a command.

Btw I also tried the same with Git Bash (file extension .sh) but the same 1 frame message case, except it's just one line so I can read the next: "bash: zdec: Command Not Found" (I guess Powershell says the same with more details I can't really read?)

So I wanted to ask if someone knows an alternative way to extract the Rom which doesn't require me opening CMD on Windows 10 or a way to fix this CMD problem. Thanks in advantage.

Replies

  • XModxGodX avatar
    XModxGodX Joined 17d ago
    Offline
    4d
    Instead of using a .bat try typing "cmd" in the directory list on windows explorer. Also I personally use these for de/compression: https://hylianmodding.com/Thread-Tools-for-decompressing-retail-roms-recompressing-any-Zelda-rom-and-correcting-CRC
    Though it's worth noting that Aegh takes several minutes to completely rebuild the ROM.
    Bananite
    URL to post:

Embed

Share banner
Image URL
HTML embed code
BB embed code
Markdown embed code

Author

Myshora avatar
Myshora Joined 24d ago
Offline
Myshora
Sign up to access this!
Sign up to access this!
Sign up to access this!

Game

Sign up to access this!

Category

Share

  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • Share on Google+
  • 0
  • 173 Views
  • 3 Posts
  • 4dSubmitted
bcp.crwdcntrl.net tracking pixel