GIMP keeps messing up vtf exports...

A Forum Thread for Team Fortress 2

For context, I've been trying to make a custom lightwarp, but every time I try to use it in-game, it looks nothing like it's supposed to. I know I'm doing it right because I follow examples from other lightwarp mods I can confirm do indeed work. I even tried exporting the otherwise unchanged vtf, and it was only until after running it through GIMP that the lightwarp stopped working as intended. I don't think I got a bad install of the vtf plugin since I got it straight from the dev website. Am I just using a wrong setting? I've been using DX1 as the default preset since VTFEdit says that that's the format the working mods use, but maybe there's something I'm missing. Some help would be greatly appreciated.

Posts

  • General Cornwaffle avatar
    General Cornwaffle Joined 8y ago
    HL2 Manager HL2:EP1 Manager HL2:EP2 Manager
    Offline
    5,993 points Ranked 829th
    14 medals 3 rare
    • 6 years a member Medal icon
    • Achieved Game Manager clearance Medal icon
    • Returned 1000 times Medal icon
    • Jellyfish Short Story Entrant Medal icon
    • 2016 Survey Participant Medal icon
    • Reached 1,000 Points Medal icon
    30d 30d
    I think it's safer to just export as tga in Gimp and import into VTFEdit to create the vtf file. When exporting a tga in Gimp, uncheck "RLE Compression" as it will degrade quality.
    Source: I use Gimp.

    The settings I use in VTFEdit for importing tga is:
    Normal Format: DXT5
    Alpha Format: BGRA8888
    Texture Type: Animated Texture

    No resize


    (Lightwarps don't relly need mipmaps, they look better without them, uncheck "Generate Mipmaps")
    (My mipmap settings: 
    "Generate Mipmaps" is checked
    Mipmap Filter: Quadratic
    Sharpen Filter: Sharpen Soft
    These give 1:1 looking mipmaps without them looking too blurry or to sharp.
    But lightwarps don't need them, so uncheck "Generate Mipmaps")


    These settings give you 1:1 quality at the expense of larger filesize.
    DXT1/5 in the Alpha Format area degrades quality.

    This is important for lightwarps, make sure to check both "Clamp S" and "Clamp T" in VTFEdit for lightwarps. This prevents them from creating little black dots and will situate them properly.
    • Win x 1
    • Helpful x 1
    • Interesting x 1
    • Thanks x 1
    • Smart x 1
    Eph. 4:31-32 | 1 Cor. 15:1-4

Embed

Share banner
Image URL:
HTML embed code:
BB embed code:
Markdown embed code:

Author

Mudkip3003 avatar
Mudkip3003 Joined 5y ago
Offline
180 points Ranked 21215th

Mudkip3003
Sign up to access this!
Sign up to access this!
Sign up to access this!

Game

Sign up to access this!

Category

Share

  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • Share on Google+

Stats

  • 167 Views
  • 2 Posts
  • 30d Submitted

More Help Threads

bcp.crwdcntrl.net tracking pixel