The Game Modding Community - Since 2001

Lag issues

A Forum Thread for Team Fortress 2 Classic

So I recently started playing and on the first server I go on I`m insanely laggy , is this ping or what? I can barely aim at all.


  • 8mo
    MarioDox avatar
    MarioDox username pic Joined 4y ago
    Mario's Company Flag Affiliation: Mario's Company
    4,844 points Ranked 1010th
    28 medals 5 rare
    • Returned 1000 times Medal icon
    • 10 submissions featured Medal icon
    • Submitted 50 Skins Medal icon
    • Became a Game Pioneer Medal icon
    • Submitted 20 Maps Medal icon
    • Reached 1,000 Points Medal icon
    MarioDox avatar
    Mario's Company Flag
    Mario's Company
    Well, it's obvious. If you connect to an american server while you're in africa (for example) don't think having good connection.

    Or the servers are dying.
  • 3mo
    the REDchanit servers are located in the western US and the server machine doesn't have the highest specs. I don't know where the vaultf4 servers are located, though.
    Grason Jant


Share banner
Image URL:
HTML embed code:
BB embed code:
Markdown embed code:


Zigg419 avatar
Zigg419 Joined 1y ago
127 points Ranked 25380th

Sign up to access this!
Sign up to access this!
Sign up to access this!
Sign up to access this!


  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • Share on Google+


  • 2 Posts
  • 8mo Submitted

Hey, you! Mascot

GameBanana is one of the oldest mod sites on the net. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation - send modders points.
  • Post: Give modders your thoughts on their work.
  • Vote: Help your favorite modders win monthly awards.
  • Flag: Alert moderators and warn members of problems with mods.
  • Watch: Get notified when mods are updated.

Interested? Sign up now!

Already a Bananite? Login tracking pixel