Detail sprites

A Forum Thread for Counter-Strike: Source

Greetings! We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending DomiTibingen points.
  • Post: Give DomiTibingen your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Join the community!

Sign up

Already a Bananite? Login

Updates

Update 2
  • Added image
DomiTibingen avatar
Member Joined 5y
1,276 points Ranked 3731st
16 medals 1 rare
  • Submitted 15 Models Medal icon
  • Became a Studio Leader Medal icon
  • Reached 1,000 Points Medal icon
  • One month a member Medal icon
  • 6 months a member Medal icon
  • 1 year a member Medal icon
DomiTibingen
7mo

Achtung! Achtung!

I started making detail sprites and a wild problem apears. !

I used "google the problem" - it was not very effective.

Anyway...

When I use "tri" and "cross" as a sprite  shape, some of sprites are dark on displacement...but not on flat surface.

But when I use normal sprite shape (cards) all detail sprites are normal.

You can see how grass trurns dark on some places in displacement square. But not in surrounding flat areas.


The problem only apear with "tri" and "cross" shapes on displacement.

In cs_militia tri and cross spries are normal on displacement.

Any solutions?

Posts

  • 7mo
    Thunderkeil avatar
    Member Joined 4y
    6,090 points Ranked 737th
    22 medals 2 legendary 4 rare
    • 15+ Entries! GameBanana’s Christmas Giveaway 2016 Medal icon
    • Returned 5000 times Medal icon
    • GameBanana’s Christmas Giveaway 2015 Day Three Winner! Medal icon
    • 8-14 Entries! GameBanana’s Christmas Giveaway 2015 Medal icon
    • Returned 1000 times Medal icon
    • GameBanana’s Christmas Giveaway 2016 Day Twenty-One Winner! Medal icon
    ''it works when use normal sprites (cards) but when use tri or cross they turns black''

    Maybe it's a self-shadowing issue? 

    Haven't really worked with detail sprites, but I know that's a problem I've seen with models, where you can untag that feature
    • Cookie x 1
    • Cheers x 1
  • 7mo
    DomiTibingen avatar
    Member Joined 5y
    1,276 points Ranked 3731st
    16 medals 1 rare
    • Submitted 15 Models Medal icon
    • Became a Studio Leader Medal icon
    • Reached 1,000 Points Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    Posted by Thunderkeil

    ''it works when use normal sprites (cards) but when use tri or cross they turns black''

    Maybe it's a self-shadowing issue? 

    Haven't really worked with detail sprites, but I know that's a problem I've seen with models, where you can untag that feature

    No. Maybe I use to much density. I'll try to fix it.

    It's only showing on displacements, not on brushes.
    Like a boss

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

DomiTibingen avatar
Member Joined 5y
1,276 points Ranked 3731st
16 medals 1 rare
  • Submitted 15 Models Medal icon
  • Became a Studio Leader Medal icon
  • Reached 1,000 Points Medal icon
  • One month a member Medal icon
  • 6 months a member Medal icon
  • 1 year a member Medal icon

DomiTibingen
Sign up to access this!
Sign up to access this!
Sign up to access this!
Sign up to access this!

Category

Stats

Posts
2
Views
390
Date Added
7mo
Date Modified
7mo
Date Updated
7mo
bcp.crwdcntrl.net tracking pixel