Lights gone, decals didn't even shown up

A Forum Thread for Half-Life

SEX! Ok, we got your attention. We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending mafon2 points.
  • Post: Give mafon2 your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Resistance is futile...

Sign up

Already a Bananite? Login

rendering errors

Hello, it's me again.

Still tinkering with my singleplayer map. Recently I've come to a problem that the level launches with no lights/shadows.

It used to be like this:



But now it's like this:



This room used to be very dark, with three spots of light.

Also, there used to be an interesting spot, where everything rendered with errors. Actually, it's still here. The pre-no-shadows screenshot:



And after the incident:



My guess that it have something to do with a huge WHITE textured room (you know, there are RED, YELLOW and probably others glowing textures?), because it started around the same time I added it (but it looks so awesome). It compiles as usual with normal settings. So your thoughts?

•••

Also, I made some decals, they seem to render in editor, but not in the game. I guess it might be something to do with the color scheme, one of them has greyish in it, but the other is pure black and white arrow.

 

Also, how do you set the color of decals?

•••

Thanks for the attention.

P.S. And bonus thing that grinds my gears: roatating doors, the ones which open up like hatches, it's a pitch-yaw guess game for me everytime.

Posts

  • 10mo
    schiff. avatar
    schiff. avatar away
    Cell 1 Flag Affiliation: Cell 1
    Member Joined 8y
    21,104 points Ranked 205th
    41 medals 4 legendary 8 rare
    • Submitted 100 Skins Medal icon
    • 30 submissions featured Medal icon
    • Reached 100 subscribers Medal icon
    • Returned 5000 times Medal icon
    • Submitted 50 WiPs Medal icon
    • 6 years a member Medal icon
    fix name for decals. use { prefix


    fix leak error, check compile logs
    one man army. avatar
    Mantra
    one man army.
  • 10mo
    mafon2 avatar
    mafon2 Offline
    Member Joined 11mo
    188 points Ranked 18907th
    decals have proper names.

    Leaks? Ok, I'll check it and update you on the situation.
  • 10mo
    mafon2 avatar
    mafon2 Offline
    Member Joined 11mo
    188 points Ranked 18907th
    Ok, we're getting closer.

    I think the root of the problem is:

    Warning: Too many direct light styles on a face(880.000000,-2736.000000,0.500000)
    <...> [Few dozens of warnings later] <...>
    Warning: Too many light styles on a face(940.000000,-1732.000000,159.990005)

    I didn't find any leaks.

    I fiddled around the map, noticed some buttons that were adressing invisible block, changed their target, deleted few excessive brushes and voila – everything works...  even the lag in one room disappeared. I don't know what just happened.

    The warnings are still present though, but map plays smoothly. Why? Beats me. And irritates, 'cause it can happen again and I'll be dancing for the rain. Again.



    Decals, I thought, maybe case sensitive, but no.

    Distorted region still here. It's like STALKER anomaly:



    Yep! I just add barriers and sign "Nothing to see here, move along".

    •••

    And bonus fun thing: I found the thread with similiar issues on the net and, what'd ya know, there were no solution just random deleting and – boom–  it works.
  • 10mo
    Admer456 avatar
    Admer456 avatar Gone!
    Member Joined 3y
    11,513 points Ranked 371st
    26 medals 1 legendary 4 rare
    • Submitted 30 Tutorials Medal icon
    • Submitted 15 Tutorials Medal icon
    • Returned 1000 times Medal icon
    • Reached 50 subscribers Medal icon
    • Received thanks 50 times Medal icon
    • One month a member Medal icon
    Too many lightstyles?

    Lightstyles are dynamic lights, you know. Flickering lights, candle lights, strobing lights etc.

    You should've removed those first :P
    Not a furry. My gf is, so... avatar
    Mantra
    Not a furry. My gf is, so...
  • 10mo
    mafon2 avatar
    mafon2 Offline
    Member Joined 11mo
    188 points Ranked 18907th
    Posted by Admer456

    Too many lightstyles?

    Lightstyles are dynamic lights, you know. Flickering lights, candle lights, strobing lights etc.

    You should've removed those first :P

    Nope. There's only one pulse in one room. On average there are about 3 lights per room with this corridor above being the most light heavy, but they are simple dim lights and anomaly piece aren't even lit.
  • 10mo
    silentrunner007 avatar
    Member Joined 10y
    2,825 points Ranked 1651st
    14 medals 1 legendary 3 rare
    • 10 years a member Medal icon
    • 6 years a member Medal icon
    • 3rd Place - 2016 Winter Mapping Contest Medal icon
    • Submitted 20 Maps Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    The no lights showing means you either had a leak or there was some sort of error during the rad part of the level compiling. That spot with the harsh shadow might be happening because of the light sources in that area. What makes sense in your brain and the way rad thinks do not always coincide. I see your lights(you using textured lighting?) but that area is also being lit from the opposite wall(looks like a window). Try blocking that window light source and see if the shadow changes. Just for sake of asking what compile tools are you using? What compile settings are you using?
    Stud Muffin avatar
    Mantra
    Stud Muffin
  • 10mo
    mafon2 avatar
    mafon2 Offline
    Member Joined 11mo
    188 points Ranked 18907th
    Posted by silentrunner007

    The no lights showing means you either had a leak or there was some sort of error during the rad part of the level compiling. That spot with the harsh shadow might be happening because of the light sources in that area. What makes sense in your brain and the way rad thinks do not always coincide. I see your lights(you using textured lighting?) but that area is also being lit from the opposite wall(looks like a window). Try blocking that window light source and see if the shadow changes. Just for sake of asking what compile tools are you using? What compile settings are you using?
    1st of all, thanks everybody for the answers.

    Now, I'm afraid to drop a brick, but I'm flattered that you think that I'm using textured light. No, it's the simple lights baked with Hammer or how's that to say right. Manipulations with opposite wall had no effect,

    I'm compiling with ZHLT.

    Ok, again, experiments gave me the solution. I think the problem was in a long brush that had more than 4 lights falling on it, I replaced it with two pieces and distortions dissapeared. It seems the more – the merrier.

    Again, thanks everybody for the answers, they nudged me into the right way.

Embed

Share banner
Image URL:
HTML embed code:
BB embed code:
Markdown embed code:

Submitter

mafon2 avatar
mafon2 Offline
Member Joined 11mo
188 points Ranked 18907th

mafon2
Sign up to access this!
Sign up to access this!
Sign up to access this!
Sign up to access this!

Category

Stats

Posts
7
Views
425
Date Added
10mo

Share

  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • Share on Google+
bcp.crwdcntrl.net tracking pixel