Official Smash Help & FAQ. Please read for help!

A Forum Thread for Super Smash Bros. for Wii U

Yo, buddy. We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending PlushYoshi points.
  • Post: Give PlushYoshi your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Resistance is futile...

Sign up

Already a Bananite? Login

Please don't make new threads for simple questions, it floods the forums. Just ask in this thread instead, thanks!

Please don't make new threads for simple questions, it floods the forums. Just ask in this thread instead, thanks!

If anyone makes a separate thread asking a simple and/or already answered question, just redirect them here.

1. Q: How do I install Texture Mods?

A: http://pastebin.com/NENj6bTV

2. Q: Where can I download Sm4shExplorer from?

A: https://gbatemp.net/threads/sm4shexplorer-wii-u-only-for-now.416118/

3. Q: How do I make/use Character Select Portraits, Battle Portraits, or Stock Icons?

A: https://www.youtube.com/watch?v=0mU0M3kHR4c

4. Q: Help! The exploit for Wii U isn't working!

A: Make sure Skype is closed, and that everything is installed properly, or check here: https://gbatemp.net/threads/tutorial-running-kexploit-5-5-x-w-haxserver-loadiine-homebrew-launcher-etc.424948/

5. Q: Can you send me the dump files for Smash 4?

A: No. This is illegal, and isn't supported by anyone. Look it up if you have to.

6. Q: How do I make custom smash levels?

 A: Check out jam1garner's Stage Editor https://gbatemp.net/threads/release-smash-4-easy-stage-editor.431409/

7. Q: Where can I submit requests for people to make Smash mods?

http://gamebanana.com/requests/add

8. Q: I still need help!

A: Google the issues first, then go here: https://discord.gg/0zc7UzZFCRaQfvw5 and if your question still isn't answered, post below.



Posts

  • 1y
    deadman22 avatar
    deadman22 avatar Dead
    DeadArt Flag Affiliation: DeadArt
    Member Joined 10y
    1,092 points Ranked 4294th
    40 medals 1 legendary 8 rare
    • Returned 5000 times Medal icon
    • 25 posts awarded Exemplary Feedback Medal icon
    • 6 years a member Medal icon
    • Submitted 100 Threads Medal icon
    • Submitted 100 Sprays Medal icon
    • Thanked 50 submitters Medal icon
    Posted by Devieus

    Posted by Mini

    Posted by Devieus

    This is probably better suited as a tutorial.

    A thread saying "if you need help ask here" and a quick FAQ wouldn't be better suited as a tutorial.

    I'd say it's helpful as a thread, but it would most certainly be better suited as tutorial. Threads get buried here at an alarming rate, that includes FAQ threads. In fact, this is the second one today (though the other is more QA than FAQ).

    Neither a thread or tutorial is going to keep people from ignoring them and making their own single question threads. You have a sizable amount of new people who don't care if what they are looking for already exists or if their question has already been answered. They think their question is unique and will make a thread rather than take time to search through the already overwhelming amount of Smash help threads. They're not going to bother with finding the tutorial section because they're not going to take the time to figure out how to navigate the site. There also isn't a Smash section for tutorials implemented yet. New members aren't going to figure out that they can add one themselves either.

     I threw up a quick "Other/Misc" section in hopes of it helping but it needs submissions in order to register a tutorial section for Smash.

    TeddyBearYoshi I'd suggesting taking the unofficial part out of this thread's title. It would also help if you included links to all relevant threads currently on site that you feel people need to see. If anyone else in the Smash community is reading this, please start uploading tutorials to the section I just linked.

    MiniDevieus, it might also help if one of you featured this thread for the next couple of days so Smash modders can see it. Although if it shows up last in the featured box it's not going to help anyways.
    (◕‿◕) murder. avatar
    Mantra
    (◕‿◕) murder.
  • 1y
    Gerg avatar
    Gerg Offline
    Member Joined 1y
    I guess asking a question on a help thread is a good start. I'm trying to set up Sm4shExplorer, but it's asking for files I don't have, and it doesn't detect my patch folder. How would I go about fixing this, and if it requires it, how would I go about dumping my game files if I downloaded it on the eShop?
    Bananite
  • 1y
    PlushYoshi avatar
    PlushYoshi Offline
    Member Joined 1y
    569 points Ranked 7749th
    Posted by Gerg

    I guess asking a question on a help thread is a good start. I'm trying to set up Sm4shExplorer, but it's asking for files I don't have, and it doesn't detect my patch folder. How would I go about fixing this, and if it requires it, how would I go about dumping my game files if I downloaded it on the eShop?
    Hmm.. well if you used ddd to dump it, it should all be there. Sometimes ddd freezes mid-dump and it may have not dumped the entire game. 

    Dumping with ddd is the same as dumping with Disc, you just need to open it manually I think.

    Professional Teddy Bear
  • 1y
    CasteHappy avatar
    CasteHappy Offline
    Member Joined 1y


    Edit: when I say "nutcheck.py" I mean "NUT_check.py" it just won't let me edit the post

    Hi! I have a problem with the "NUTcheck.py" file.

    I was trying to extract textures for the first time today and when I had to type "
    NUT
    check.py model.nut" in the command window, it does nothing. It just shows the prompt again. The "OutDDS" folder is empty.

    Am I doing something wrong? missing? I installed Python 2.7 before even downloading those files, so I don't know what the problem is.

    Note: The first time I tried doing that, I had to change the default program for "nutcheck.py" manually because it didn't have any program set. I chose python.exe.

    Thank you! 
    Bananite
  • 1y
    PlushYoshi avatar
    PlushYoshi Offline
    Member Joined 1y
    569 points Ranked 7749th
    Posted by CasteHappy

    Hi! I have a problem with the NUTcheck file

    I was trying to extract textures for the first time today, and when I had to type nut
    check.py model.nut" in the command window, it does nothing. It just shows the prompt again. The "OutDDS" folder is empty.

    Am I doing something wrong? missing? I installed Python 2.7 before even downloading those files, so I don't know what the problem is.

    Note: The first time I tried doing that, I had to change the default program for "nutcheck.py" manually because it didn't have any program set. I chose python.exe.

    Thank you! 

    It's supposed to be "NUT_check.py", not "nutcheck.py" according to someone I know. 
    Professional Teddy Bear
  • 1y
    CasteHappy avatar
    CasteHappy Offline
    Member Joined 1y
    Posted by TeddyBearYoshi

    Posted by CasteHappy

    Hi! I have a problem with the NUTcheck file

    I was trying to extract textures for the first time today, and when I had to type nut
    check.py model.nut" in the command window, it does nothing. It just shows the prompt again. The "OutDDS" folder is empty.

    Am I doing something wrong? missing? I installed Python 2.7 before even downloading those files, so I don't know what the problem is.

    Note: The first time I tried doing that, I had to change the default program for "nutcheck.py" manually because it didn't have any program set. I chose python.exe.

    Thank you! 

    It's supposed to be "NUT_check.py", not "nutcheck.py" according to someone I know. 
    I mispelled that here, my fault. I know I typed it right everytime in the command window, I have a screenshot that I wanted to upload where I type the same thing like 4 times and it doesn't work. I'll edit the previous post

    Bananite
  • 1y
    Gerg avatar
    Gerg Offline
    Member Joined 1y
    Posted by TeddyBearYoshi

    Posted by Gerg

    I guess asking a question on a help thread is a good start. I'm trying to set up Sm4shExplorer, but it's asking for files I don't have, and it doesn't detect my patch folder. How would I go about fixing this, and if it requires it, how would I go about dumping my game files if I downloaded it on the eShop?
    Hmm.. well if you used ddd to dump it, it should all be there. Sometimes ddd freezes mid-dump and it may have not dumped the entire game. 

    Dumping with ddd is the same as dumping with Disc, you just need to open it manually I think.

    Oh, so dumping's required then. How would I go about doing that?
    Bananite
  • 1y
    PlushYoshi avatar
    PlushYoshi Offline
    Member Joined 1y
    569 points Ranked 7749th
    Posted by Gerg

    Posted by TeddyBearYoshi

    Posted by Gerg

    I guess asking a question on a help thread is a good start. I'm trying to set up Sm4shExplorer, but it's asking for files I don't have, and it doesn't detect my patch folder. How would I go about fixing this, and if it requires it, how would I go about dumping my game files if I downloaded it on the eShop?
    Hmm.. well if you used ddd to dump it, it should all be there. Sometimes ddd freezes mid-dump and it may have not dumped the entire game. 

    Dumping with ddd is the same as dumping with Disc, you just need to open it manually I think.

    Oh, so dumping's required then. How would I go about doing that?
    In the first tutorial/link.

    Professional Teddy Bear
  • 1y
    CrimsonKhaos avatar
    Member Joined 1y
    431 points Ranked 9863rd
    Okay so everything was going silky smooth until I had to open up the Sm4shFileExplorer to do this step. When it asks you to select the latest version of the game, go to "Computer" -> "C:/" -> "Smash" -> "vol".  When I tried to do this, a window pops up saying "Warning. It seems that the game folder selected does not contain a patch folder." Is there any way I can fix this? I can provide screenshots if needed.  Thanks!
    Your pal Crimmy
  • 1y
    deadman22 avatar
    deadman22 avatar Dead
    DeadArt Flag Affiliation: DeadArt
    Member Joined 10y
    1,092 points Ranked 4294th
    40 medals 1 legendary 8 rare
    • Returned 5000 times Medal icon
    • 25 posts awarded Exemplary Feedback Medal icon
    • 6 years a member Medal icon
    • Submitted 100 Threads Medal icon
    • Submitted 100 Sprays Medal icon
    • Thanked 50 submitters Medal icon
    bump to bring this to the very top.
    (◕‿◕) murder. avatar
    Mantra
    (◕‿◕) murder.
  • 1y
    PlushYoshi avatar
    PlushYoshi Offline
    Member Joined 1y
    569 points Ranked 7749th
    Posted by CrimsonKhaos

    Okay so everything was going silky smooth until I had to open up the Sm4shFileExplorer to do this step. When it asks you to select the latest version of the game, go to "Computer" -> "C:/" -> "Smash" -> "vol".  When I tried to do this, a window pops up saying "Warning. It seems that the game folder selected does not contain a patch folder." Is there any way I can fix this? I can provide screenshots if needed.  Thanks!
    I believe it means you need to download the latest update with UWizard, or something similar.

    Professional Teddy Bear
  • 1y
    Mini avatar
    Mini avatar Always Watching
    Admin Joined 10y
    3,547 points Ranked 1302nd
    44 medals 5 legendary 8 rare
    • 1st Place - Winter Sprays Contest Medal icon
    • Guardian of the Acid Milk Medal icon
    • Achieved Admin clearance Medal icon
    • Returned 5000 times Medal icon
    • 10 years a member Medal icon
    • 2nd Place - GameBanana Around the Globe Contest Medal icon
    Mini avatar
    Mini
    Community Wizard
    Stickied (thanks tom for re-adding the feature).

    Edit: Made a few tweaks to the thread to hopefully grab people's attention a bit more.
    • Agree x 2
    • Epic win x 1
    • Helpful x 1
    • Thanks x 1
    Sometimes I'm just not sure avatar
    Mantra
    Sometimes I'm just not sure
  • 1y
    newguyne avatar
    newguyne Offline
    Member Joined 1y
    hello there, i have got a question
    i would like to mod my sm4sh, or to be specific, to buff mewtwo. 
    i started dumping the game, but it seems it will take me like around 21 hours or so. thus i only wanted minor changes, i wanted to ask if there is some place where i could ask people to maybe do the mod for me, maybe even here? i am posting this questions into this thread because as i saw, threads for small questions/topics are not very appreciated
    i would like to give you some details about what i imagined:
    -weight buff to 117
    - increasing the range of his grab (additional 1/3 range?)
    - forward throw doing 19 percent damage in total
    - increasing up- and back throw's knockback, so that heavy weight characters get koed at around 96% damage at the middle of the stage, with no rage
    - increasing the range of his down special (maybe additional 3/4 range?) 

    i am very sorry for being so demanding, i hope i am not impudently or seem rude
    again, i didn't know where's to post this and i hope i didn't break any rules or offended somebody
    i would be very happy if somebody could help me with this issue, hopefully my language wasn't too bad, i am no native english speaker

    have a great day :)
    Bananite
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by newguyne

    hello there, i have got a question
    i would like to mod my sm4sh, or to be specific, to buff mewtwo. 
    i started dumping the game, but it seems it will take me like around 21 hours or so. thus i only wanted minor changes, i wanted to ask if there is some place where i could ask people to maybe do the mod for me, maybe even here? i am posting this questions into this thread because as i saw, threads for small questions/topics are not very appreciated
    i would like to give you some details about what i imagined:
    -weight buff to 117
    - increasing the range of his grab (additional 1/3 range?)
    - forward throw doing 19 percent damage in total
    - increasing up- and back throw's knockback, so that heavy weight characters get koed at around 96% damage at the middle of the stage, with no rage
    - increasing the range of his down special (maybe additional 3/4 range?) 

    i am very sorry for being so demanding, i hope i am not impudently or seem rude
    again, i didn't know where's to post this and i hope i didn't break any rules or offended somebody
    i would be very happy if somebody could help me with this issue, hopefully my language wasn't too bad, i am no native english speaker

    have a great day :)
    While I can't really help you with Mewtwo's moveset, I can tell you that the file named "fighter_param.bin" contains the attributes for all the fighters. Mewtwo's attributes will be in Entry[51], but you do need to use a parameter editing tool to even do this.
    Texture & Moveset Editor
  • 1y
    Joshd123 avatar
    Joshd123 Offline
    Member Joined 1y
    When I launch smash bros for Wii U with a skin for a character it crashes at the title screen. I'm thinking that  it is  because of the skin not packing but i don't know how to make it pack when i hit build the mod it packs everything except c08. Does anyone know how to fix this?
    Bananite
  • 1y
    PlushYoshi avatar
    PlushYoshi Offline
    Member Joined 1y
    569 points Ranked 7749th
    Posted by Joshd123

    When I launch smash bros for Wii U with a skin for a character it crashes at the title screen. I'm thinking that  it is  because of the skin not packing but i don't know how to make it pack when i hit build the mod it packs everything except c08. Does anyone know how to fix this?
    Right click on c08 and click remove mod files in Sm4shExplorer.

    Professional Teddy Bear
  • 1y
    Joshd123 avatar
    Joshd123 Offline
    Member Joined 1y
    Posted by TeddyBearYoshi

    Posted by Joshd123

    When I launch smash bros for Wii U with a skin for a character it crashes at the title screen. I'm thinking that  it is  because of the skin not packing but i don't know how to make it pack when i hit build the mod it packs everything except c08. Does anyone know how to fix this?
    Right click on c08 and click remove mod files in Sm4shExplorer.

    That didn't work all it did was remove c08.

    Bananite
  • 1y
    PlushYoshi avatar
    PlushYoshi Offline
    Member Joined 1y
    569 points Ranked 7749th
    Posted by Joshd123

    Posted by TeddyBearYoshi

    Posted by Joshd123

    When I launch smash bros for Wii U with a skin for a character it crashes at the title screen. I'm thinking that  it is  because of the skin not packing but i don't know how to make it pack when i hit build the mod it packs everything except c08. Does anyone know how to fix this?
    Right click on c08 and click remove mod files in Sm4shExplorer.

    That didn't work all it did was remove c08.


    c08 was the mod costume. Default costumes go from c00-c07.
    Professional Teddy Bear
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by TeddyBearYoshi

    c08 was the mod costume. Default costumes go from c00-c07.
    The only exception to this rule is for Little Mac, where he has 16 palette swaps. In that case, his outfit choices go from c00-c15.
    Texture & Moveset Editor
  • 1y
    Curious Villager avatar
    Member Joined 1y
    327 points Ranked 12274th
    I'm a bit curious in regards to the worldsmash_camera_param.bin file located within the data(region) > param > worldsmash folder. Does anyone know if this is the file that is used for the camera control when the game is paused, or is it for the camera control during gameplay?

    Bananite
  • 1y
    Anamalgam avatar
    Anamalgam Offline
    Member Joined 1y
    So im trying to change the hair color for palutena and i found a guide on how to do so. However the guide is geared toward people who know how to program, which I am not. I followed the guide given for the material editor and I got to the point where it tells you to change the values in the "file", however looking at them makes no sense whatsoever to me. Anybody who knows how to do it think they can help me out? Im trying to make her hair color pink.

    What the "Out" file text looks like

    ObjName:hair_O_OBJ_O_SORTEACHNODE_polygon1NU_colorSamplerUV,1.000000,1.000000,-0.050000,0.000000NU_fresnelColor,0.914000,0.914000,0.914000,0.000000

    ObjName:hair_O_OBJ_O_SORTEACHNODE_polygon2NU_colorSamplerUV,1.000000,1.000000,-0.050000,0.000000NU_fresnelColor,0.914000,0.914000,0.914000,0.000000

    Bananite
  • 1y
    Foaya avatar
    Foaya Offline
    Member Joined 1y
    494 points Ranked 8833rd
    Hello !

     I need some help, I've been trying to create my first texture mod for smash 4 today, i'm pretty much done with it but I still have an issue with the texture of the hair that I can't fix...


    (You can't see it too well with the small size of the picture but click on it to see it better)

    If anyone know a way to solve this it'll be gladly appreciated !

    Thanks
    Dr Pepper for Life
  • 1y
    xdrako23x avatar
    xdrako23x Offline
    Member Joined 1y
    Is there a way the extract packed file.

    Since I deleted by error my work folder.

    ps: How can I add voice to only one costume?
    Bananite
  • 1y
    BaronHumbert avatar
    Member Joined 1y
    123 points Ranked 24657th
    So I'm on the step after dumping the game but once I locate the vol folder with sm4shfileexplorer it tells me 'warning it seems the game folder does not contain a patch folder' and when I click the Smash folder it tells me I need: 
    vol\content\Is 
    vol\meta\meta.xml
    vol\code\cross_f.rpx
    I have all of those except the meta file
    Bananite
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by BaronHumbert

    So I'm on the step after dumping the game but once I locate the vol folder with sm4shfileexplorer it tells me 'warning it seems the game folder does not contain a patch folder' and when I click the Smash folder it tells me I need: 
    vol\content\Is 
    vol\meta\meta.xml
    vol\code\cross_f.rpx
    I have all of those except the meta file
    When you dump your ISO, you should have ALL the required files for using Sm4shExplorer. If it helps, please do not end the dumping process prematurely, as that could be one of your problems.
    Texture & Moveset Editor
  • 1y
    xdrako23x avatar
    xdrako23x Offline
    Member Joined 1y
    Where are the mods for the 3ds version of the game?
    Bananite
  • 1y
    spongegar avatar
    spongegar Offline
    Member Joined 1y
    Will the intro cut scene be limited to 1:47 or will anyone be able to extend that? 
    Bananite
  • 1y
    NintendoPSX avatar
    Member Joined 1y
    609 points Ranked 7293rd
    So I'm having issues with Link while doing 3DS Max/texture edits.
    So I've been trying to vertex edit and texture edit, mostly success. Until I vertex shrink/hide certain textures on Link. His arm guard and the stiches on his chest. When shrunk and hidden, they leave a massive mesh of gradient and I don't know why. The same for the straps/buckle the arm guard is attached to on his arm. I can't figure out how to clean up this gradient so it's just one color. Please help.


    Bananite
  • 1y
    maito avatar
    maito Offline
    Member Joined 1y
    Hey! So, every time I edit any eye texture whatsoever and inject it, the textures appear pixely as if the resolution has been lowered. I have no idea what's doing this, and I've wasted hours trying to figure this out. Anyone have any tips?

    :]
  • 1y
    Murkiri avatar
    Murkiri Offline
    Member Joined 1y
    209 points Ranked 17205th
    Hey. I've been doing some texture hacks with injectpack it doesn't seem to be injecting it into the model.nut file. I put it into Sm4shExplorer when i load the game it is just the regular skin. I also extracted the model.nut file after injecting the textures and it is just the regular skin. pls help 
    *Blip*
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by Murkiri

    Hey. I've been doing some texture hacks with injectpack it doesn't seem to be injecting it into the model.nut file. I put it into Sm4shExplorer when i load the game it is just the regular skin. I also extracted the model.nut file after injecting the textures and it is just the regular skin. pls help 
    Make sure that none of the .dds files are set as read-only. Apparently, the tools don't like to handle read-only files.
    Texture & Moveset Editor
  • 1y
    The Hypist avatar
    The Hypist Offline
    Member Joined 1y
    1,013 points Ranked 4615th
    7 medals 1 rare
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    • Submission featured Medal icon
    I have mods with Custom CSPs, and when I play a match with them and go back to the CSS, the portrait goes back to the default version. Basically, it goes back to showing the original costume the modded CSP was in place of.

    Does anyone know why this happens? If so, is there a way I can fix it? I appreciate the help.
    Heir to the Monado
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by The Hypist

    I have mods with Custom CSPs, and when I play a match with them and go back to the CSS, the portrait goes back to the default version. Basically, it goes back to showing the original costume the modded CSP was in place of.

    Does anyone know why this happens? If so, is there a way I can fix it? I appreciate the help.
    Please keep the following info in mind.

    chr_11 = Character portrait
    chr_13 = Large character portrait

    Is it possible that the owner of the hack failed to cover all of the interface portraits for the specific fighter? My own portraits have been working just fine.
    Texture & Moveset Editor
  • 1y
    The Hypist avatar
    The Hypist Offline
    Member Joined 1y
    1,013 points Ranked 4615th
    7 medals 1 rare
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    • Submission featured Medal icon
    Posted by Mario and Sonic Guy

    Please keep the following info in mind.

    chr_11 = Character portrait
    chr_13 = Large character portrait

    Is it possible that the owner of the hack failed to cover all of the interface portraits for the specific fighter? My own portraits have been working just fine.
    So, do I wait for the modders to make different CSPs? There are plenty of mods I have this problem with, I really don't want to wait to fix all of it.

    Heir to the Monado
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by The Hypist

    So, do I wait for the modders to make different CSPs? There are plenty of mods I have this problem with, I really don't want to wait to fix all of it.
    If worse comes to worse, you could always make the portraits yourself.
    Texture & Moveset Editor
  • 1y
    The Hypist avatar
    The Hypist Offline
    Member Joined 1y
    1,013 points Ranked 4615th
    7 medals 1 rare
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    • Submission featured Medal icon
    Posted by Mario and Sonic Guy

    If worse comes to worse, you could always make the portraits yourself.
    I saw a video of someone using mods, and after their match, the CSP stayed the same. Mine always goes back to default. I looked on Sm4shExplorer for a reason why this happens, but I don't know. I also have the same mod as the person in the video (Sunshine Dr. Mario) and the CSP still goes back to normal.

    I guess for now, it can't be helped. But I would appreciate if someone were to research this problem. Thanks anyways.
    Heir to the Monado
  • 1y
    Keeperfim avatar
    Keeperfim Offline
    Member Joined 1y
    I'm having some problems with some of my extra costumes. I've got red gloves on all additional mario alts, red tipped hair on my 10th peach costume, red hair on all additional tlink alts, weird black texture over the eyes of my my extra corrin alt, red eyes on my extra ROB alt, red glasses on both my extra Falcon alts. 

    Curiously, the alts on all these characters work with no issues: Luigi, Little Mac, Link, Zero Suit Samus, King Dedede, Lucario, Lucina, Mega Man, and Roy. I think it's something to do with adding extra costume slots. Everything has been properly TexIDfix'd.

    Some pictures: http: //imgur.com/a/WI9mC
    Bananite
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by The Hypist

    I saw a video of someone using mods, and after their match, the CSP stayed the same. Mine always goes back to default. I looked on Sm4shExplorer for a reason why this happens, but I don't know. I also have the same mod as the person in the video (Sunshine Dr. Mario) and the CSP still goes back to normal.

    I guess for now, it can't be helped. But I would appreciate if someone were to research this problem. Thanks anyways.
    What's your region? This really shouldn't happen for the NTSC-U version, but I can't exactly help you if this is a PAL version issue.
    Texture & Moveset Editor
  • 1y
    The Hypist avatar
    The Hypist Offline
    Member Joined 1y
    1,013 points Ranked 4615th
    7 medals 1 rare
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    • Submission featured Medal icon
    Posted by Mario and Sonic Guy

    What's your region? This really shouldn't happen for the NTSC-U version, but I can't exactly help you if this is a PAL version issue.

    I'm in the US, so NTSC-U. I used U-Wizard to get the patch files, that's how I know.
    Heir to the Monado
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by The Hypist

    I'm in the US, so NTSC-U. I used U-Wizard to get the patch files, that's how I know.
    If the portraits that you're talking about are for the DLC fighters, then you have to replace the DLC portraits that are inside ALL of the language folders as well. For the NTSC-U version, this includes data(us_fr) and data(us_sp).
    Texture & Moveset Editor
  • 1y
    The Hypist avatar
    The Hypist Offline
    Member Joined 1y
    1,013 points Ranked 4615th
    7 medals 1 rare
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    • Submission featured Medal icon
    Posted by Mario and Sonic Guy

    If the portraits that you're talking about are for the DLC fighters, then you have to replace the DLC portraits that are inside ALL of the language folders as well. For the NTSC-U version, this includes data(us_fr) and data(us_sp).
    I have a different problem now. I'm trying to make my own CSP, and I put my edited DDS File in the same folder as the Nut File. Then when I run EasyInject, a command prompt window pops up for a split second, then disappears, so I don't have time to read it.

    I have no idea what it says, it read something like "error", and I'm really stuck on this. I really don't mean to be a bother, as you can see I'm not an expert modder. Still, I appreciate all the help I can get.

    Heir to the Monado
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by The Hypist

    I have a different problem now. I'm trying to make my own CSP, and I put my edited DDS File in the same folder as the Nut File. Then when I run EasyInject, a command prompt window pops up for a split second, then disappears, so I don't have time to read it.

    I have no idea what it says, it read something like "error", and I'm really stuck on this. I really don't mean to be a bother, as you can see I'm not an expert modder. Still, I appreciate all the help I can get.
    Make sure that you're using the correct texture format for your portraits.

    chr_00 = ARGB_8888
    chr_11 = DXT5
    chr_12 = DXT5
    chr_13 = DXT5
    stock_90 = ARGB_8888

    You do not have to worry about MIP maps though, since that's only really needed for the 3D models.
    Texture & Moveset Editor
  • 1y
    Platinum_PLTM avatar
    Member Joined 1y
    580 points Ranked 7613rd
    For some reason, whenever I load up my mods, the menu and stages almost always play the same song, and I don't know why. No, I don't have it set that way in My Music.
    hey kid want some memes?
  • 1y
    Perhaps this has been discussed elsewhere, but does anybody know why Kirby's hats cause him to T-pose over extra costume slots? If it's an easy fix, I'd love to hear what to do - it's a bit problematic for me at the moment.
    Bananite
  • 1y
    PlushYoshi avatar
    PlushYoshi Offline
    Member Joined 1y
    569 points Ranked 7749th
    Posted by Kamecasa

    Perhaps this has been discussed elsewhere, but does anybody know why Kirby's hats cause him to T-pose over extra costume slots? If it's an easy fix, I'd love to hear what to do - it's a bit problematic for me at the moment.
    It may have something to do with Sm4shExplorer, nobody is really sure about that right now.

    Professional Teddy Bear
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    This probably can't be answered right now, but I've been looking around my ISO dump to see where the tip information would be stored. I'm not having much luck outside of a single parameter file though, and even that isn't all too helpful.
    Texture & Moveset Editor
  • 1y
    _D0ct0r_ avatar
    _D0ct0r_ avatar Offline
    Member Joined 1y
    1,373 points Ranked 3425th
    8 medals 1 rare
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • Submitted 10 Sounds Medal icon
    • Reached 1,000 Points Medal icon
    I'm having a bit of a strange issue. I tried downloading my first GameBanana mods which was True Dark Bowser by DeadMK, but the game doesn't load the mod. I put the "c08" file onto the "body" folder of Bowser, put the "Ch_Koopa" files into the corresponding "Ch" files, and finally, after both the "Fighter" and "UI" files turned green, I built the mod. I renamed the "release" folder to "patch" and put it into the numbered folder in my SD card. Upon starting the game, no such mods were present. It's as if the game completely ignored the mods to begin with. My music mods still worked, which made me even more confused. If I could get help on this situation, I would greatly appreciate it! 
    Melee Elitist
  • 1y
    Mario and Sonic Guy avatar
    Mario and Sonic Guy See ya later!
    Member Joined 1y
    2,640 points Ranked 1745th
    14 medals 2 rare
    • Submitted 50 Skins Medal icon
    • Returned 1000 times Medal icon
    • Submitted 10 Skins Medal icon
    • One month a member Medal icon
    • Reached 1,000 Points Medal icon
    • Received thanks 5 times Medal icon
    Posted by Marth_of_Altea

    I'm having a bit of a strange issue. I tried downloading my first GameBanana mods which was True Dark Bowser by DeadMK, but the game doesn't load the mod. I put the "c08" file onto the "body" folder of Bowser, put the "Ch_Koopa" files into the corresponding "Ch" files, and finally, after both the "Fighter" and "UI" files turned green, I built the mod. I renamed the "release" folder to "patch" and put it into the numbered folder in my SD card. Upon starting the game, no such mods were present. It's as if the game completely ignored the mods to begin with. My music mods still worked, which made me even more confused. If I could get help on this situation, I would greatly appreciate it! 
    You probably forgot a step that's important for adding new CSS slots. You also need to edit a file named "ui_character_db.bin".
    Texture & Moveset Editor
  • 1y
    _D0ct0r_ avatar
    _D0ct0r_ avatar Offline
    Member Joined 1y
    1,373 points Ranked 3425th
    8 medals 1 rare
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • Submitted 10 Sounds Medal icon
    • Reached 1,000 Points Medal icon
    Posted by Mario and Sonic Guy

    Posted by Marth_of_Altea

    I'm having a bit of a strange issue. I tried downloading my first GameBanana mods which was True Dark Bowser by DeadMK, but the game doesn't load the mod. I put the "c08" file onto the "body" folder of Bowser, put the "Ch_Koopa" files into the corresponding "Ch" files, and finally, after both the "Fighter" and "UI" files turned green, I built the mod. I renamed the "release" folder to "patch" and put it into the numbered folder in my SD card. Upon starting the game, no such mods were present. It's as if the game completely ignored the mods to begin with. My music mods still worked, which made me even more confused. If I could get help on this situation, I would greatly appreciate it! 
    You probably forgot a step that's important for adding new CSS slots. You also need to edit a file named "ui_character_db.bin".
    Could you give me a run-down on how to do that, please? 

    Melee Elitist
  • 1y
    Hey, if anyone could help me here I'd appreciate it

    So I have my sm4sh dumped to my PC, and want to make custom textures for a character. I've already extracted the model.nut for the character and put it in the InjectPack folder. The problem is whenever I open up command prompt and type "NUT_check.py model.nut" I get IndexError: list index out of range and nothing in the OutDDS folder. How can I fix this?
    Bananimite avatar
    Mantra
    Bananimite

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

PlushYoshi avatar
PlushYoshi Offline
Member Joined 1y
569 points Ranked 7749th

PlushYoshi
Sign up to access this!
Sign up to access this!
Sign up to access this!
Sign up to access this!

Category

Attributes

Stats

Posts
318
Views
22,078
Date Added
1y
Date Modified
9mo

Featurings

  • Staff Pick Jul 16 2016
bcp.crwdcntrl.net tracking pixel