Ads keep us online. Without them, we wouldn't exist. We don't have paywalls or sell mods - we never will. But every month we have large bills and running ads is our only way to cover them. Please consider unblocking us. Thank you from GameBanana <3

SourceMod:How to make custom model viewable to all

A Forum Thread for Team Fortress 2

No ads for members. Membership is 100% free. Sign up!

Hello I am having some trouble getting my model to be viewable to everyone on the server.

Hello again. The problem this time is that I am having trouble getting a custom item model to be viewable to everyone on a server. This server is running SourceMod, and I am making it for the owner. I don't really have that much experience with SourceMod, but here's what I know. 1] We have replaced one of valve's employe badges with this item. 2] The model is equippable through a !donor menu 3] Once equipped, the model is only visible to that player. If anyone has experience with this please reply. We've been trying to get this working for hours with no results...
Sign up to access this!
  • birjolaxew avatar
    birjolaxew username pic Joined 9y ago
    Offline
    4,335 points Ranked 1594th
    2 medals 1 legendary
    • 1st Place - Tutorial Contest Medal icon
    • Received thanks 5 times Medal icon
    access_time 7y
    What's your current code?
    Is the item only visible to the player that it is equipped on, or only you/anyone who previously downloaded the model?
    URL to post:
  • Kobalt Kitsune avatar
    Kobalt Kitsune Joined 7y ago
    Offline
    106 points Ranked 68124th
    access_time 7y
    > **Posted by birjolaxew** > What's your current code?
    > Is the item only visible to the player that it is equipped on, or only you/anyone who previously downloaded the model? The current code for the .qc is this: $cd "C:\Users\DL\Desktop\tailmodels" $modelname "player\pf2\tails\tail_twilight.mdl" $model "body" "tail_twilight.smd" $cdmaterials "models\player\pf2\tails\twilight\" $cdmaterials "" $hboxset "default" $jigglebone "tail2" { is_flexible { tip_mass 50 yaw_stiffness 100 yaw_damping 3 pitch_damping 3 length 25 pitch_constraint -10 10 yaw_constraint -10 10 yaw_friction 2 pitch_friction 2 } } $jigglebone "tail3" { is_flexible { tip_mass 50 yaw_stiffness 100 yaw_damping 3 pitch_damping 3 length 25 pitch_constraint -10 10 yaw_constraint -10 10 yaw_friction 2 pitch_friction 2 } } $jigglebone "jiggle_tail1" { is_flexible { tip_mass 100 yaw_stiffness 100 yaw_damping 3 pitch_damping 3 length 25 pitch_constraint -10 10 yaw_constraint -10 10 yaw_friction 2 pitch_friction 2 } } $jigglebone "jiggle_tail2" { is_flexible { tip_mass 100 yaw_stiffness 100 yaw_damping 3 pitch_damping 3 length 25 pitch_constraint -10 10 yaw_constraint -10 10 yaw_friction 2 pitch_friction 2 } } $surfaceprop "plastic" $attachment "tail" "bip_pelvis" 0.00 0.00 0.00 rotate 0.00 0.00 0.00 $sequence idle "tail_twilight.smd" fps 30.00 As for the item, it is only visible to the player that has it equipped. I honestly have no idea how I'm going to fix this. I had originally thoyght that it was because of sv_pure or something, but that wasn't it either. :/
    1101
    URL to post:
  • RandomPerson78642 avatar
    RandomPerson78642 username pic Joined 7y ago
    Offline
    4,319 points Ranked 1604th
    15 medals 1 legendary 2 rare
    • Reached 100 subscribers Medal icon
    • Reached 50 subscribers Medal icon
    • 6 years a member Medal icon
    • Tutorial Contest Entrant Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    access_time 7y
    I think he meant the code to the plugin. And remind me not go to _that_ server. XD I assume you got the model working?
    URL to post:
  • birjolaxew avatar
    birjolaxew username pic Joined 9y ago
    Offline
    4,335 points Ranked 1594th
    2 medals 1 legendary
    • 1st Place - Tutorial Contest Medal icon
    • Received thanks 5 times Medal icon
    access_time 7y
    Yeah, I'm talking about what method you used to "equip" the item in the plugin.
    URL to post:
  • Ghost1229127 avatar
    Ghost1229127 Joined 9y ago
    Dave's Here
    4,940 points Ranked 1381st
    23 medals 1 legendary 3 rare
    • Became a Ripe Supporter Medal icon
    • Reached 50 subscribers Medal icon
    • 6 years a member Medal icon
    • Returned 1000 times Medal icon
    • GAMEBANANA Spray Contest Entrant Medal icon
    • Tooler of the Month, January 2013 Medal icon
    access_time 7y
    Head over to forums.alliedmods.net, and post this question there. They're much more suited to help you with this.
    URL to post:
  • Kobalt Kitsune avatar
    Kobalt Kitsune Joined 7y ago
    Offline
    106 points Ranked 68124th
    access_time 7y
    > **Posted by SergeantJoe** > I think he meant the code to the plugin. > > And remind me not go to _that_ server. XD > > I assume you got the model working? No, I'm not quite there yet. I still need to fix the particle system, get a few more of the basic animations going, and find out why the model is causing TF2 to randomly crash (without displaying any error messages in the console) after a certain amount of time. Also, please remember all these mods I'm working on are in development, and are not actually implemented in the server. _Yet_ ;P > **Posted by birjolaxew** > Yeah, I'm talking about what method you used to "equip" the item in the plugin. I'll have to ask the server owner about that. I don't have access to the server files.
    1101
    URL to post:
  • Kobalt Kitsune avatar
    Kobalt Kitsune Joined 7y ago
    Offline
    106 points Ranked 68124th
    access_time 7y
    > **Posted by 404: User Not Found** > Head over to forums.alliedmods.net, and post this question there. > > They're much more suited to help you with this. Actually, I've already made a thread there. lol It's got 35 views so far, but no replies. https://forums.alliedmods.net/showthread.php?t=219602
    1101
    URL to post:
  • Kobalt Kitsune avatar
    Kobalt Kitsune Joined 7y ago
    Offline
    106 points Ranked 68124th
    access_time 7y
    Okay, so I found out the reason why it's not working. It's because valve banned server-side custom player attachments. If anyone has found a way to circumvent this please pm me.
    1101
    URL to post:

Embed

Share banner
Image URL
HTML embed code
BB embed code
Markdown embed code

Author

Kobalt Kitsune avatar
Kobalt Kitsune Joined 7y ago
Offline
106 points Ranked 68124th
Kobalt Kitsune
Sign up to access this!
Sign up to access this!
Sign up to access this!

Game

Sign up to access this!

Category

Share

  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • 0
  • 2.7k
  • 8
  • 7y

More from Submitter

More Help Threads