***Help w/CS:S Mapping

A Forum Thread for Counter-Strike: Source

Members see zero ads. Membership is 100% free

Compile Log

Hey guys, I am mapping for CS:Source and my compile window says (Not Responding) but then finishes compiling. Can anyone view this compile log and see what the problem is and offer advice or guidance to me so I can fix it and move on?
  • Devieus avatar
    Devieus username pic Joined 9y ago
    Moderator
    OFFLINE
    ?
    92,467 points Ranked 38th
    70 medals 6 legendary 13 rare
    • 1st Place - Tutorial Contest Medal icon
    • 15+ Entries! GameBanana’s Christmas Giveaway 2015 Medal icon
    • Returned 5000 times Medal icon
    • 15+ Entries! GameBanana’s Christmas Giveaway 2016 Medal icon
    • 2017 Top Contributor Medal icon
    • 15+ Entries! GameBanana’s Christmas Giveaway 2017 Medal icon
    7y
    Your map sprung a leak, and you have 'tools/nodraw' on a displacement. Load the point file to see where the leak is, and destroy the displacements with nodraw.
    Sentinel of the TV remote avatar
    Mantra
    Sentinel of the TV remote
    URL to post:
  • BrainZ avatar
    BrainZ username pic Joined 12y ago
    Offline
    16,115 points Ranked 329th
    19 medals 1 legendary 1 rare
    • 10 years a member Medal icon
    • 6 years a member Medal icon
    • GAMEBANANA Spray Contest Entrant Medal icon
    • Became a Club Leader Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    7y
    Don't put compilelogs in images, use pastebin or something.
    • Dumb x 1
    gone avatar
    Mantra
    gone
    URL to post:
  • Mike C avatar
    Mike C Joined 7y ago
    Offline
    3,434 points Ranked 2317th
    7y
    > **Posted by Devieus** > Your map sprung a leak, and you have 'tools/nodraw' on a displacement. > > Load the point file to see where the leak is, and destroy the displacements with nodraw. I sculpted terrain to appear to be mountainous and I no_draw'ed the entire block (besides) the face. I will fix it and recompile and get back to you, but that does appear to be the problem. Thanks man!
    "risOsi"
    URL to post:
  • Fibbs avatar
    Fibbs username pic Joined 11y ago
    Offline
    32,089 points Ranked 140th
    24 medals 1 rare
    • 6 years a member Medal icon
    • Prefaber of the Month, June 2012 Medal icon
    • MiPper of the Month, June 2012 Medal icon
    • Prefaber of the Month, March 2013 Medal icon
    • Texturer of the Month, July 2014 Medal icon
    • Became a Studio Leader Medal icon
    7y
    > **Posted by risOsi** > > **Posted by Devieus** > > > Your map sprung a leak, and you have 'tools/nodraw' on a displacement. > > > > Load the point file to see where the leak is, and destroy the displacements with nodraw. > > I sculpted terrain to appear to be mountainous and I no_draw'ed the entire block (besides) the face. I will fix it and recompile and get back to you, but that does appear to be the problem. Thanks man! When making displacements be sure to only select the face you want to turn into a displacement instead of selecting the whole brush. Also, the compile log window not responding is not an issue, it's just busy compiling to handle anything else (at a guess), the compile process will still continue just fine. Your main issue is that you have a leak, though. When you have a leak it will say "\*** leaked \***" in the compile log, as it does with yours, however it will usually also refer to the entity closest to the leak (eg "Entity light (-1607.69 -1094.12 -183.00) leaked!" (also note that the mentioned entity is not at all at fault, unless its origin is outside of the map)). Make sure you have at least one entity in the map else VBSP can't check for leaks and will always spit out "*** leaked***" even if there isn't a leak.
    URL to post:
  • Mike C avatar
    Mike C Joined 7y ago
    Offline
    3,434 points Ranked 2317th
    7y
    > **Posted by Fibbs** > > **Posted by risOsi** > > > > **Posted by Devieus** > > > > > Your map sprung a leak, and you have 'tools/nodraw' on a displacement. > > > > > > Load the point file to see where the leak is, and destroy the displacements with nodraw. > > > > I sculpted terrain to appear to be mountainous and I no_draw'ed the entire block (besides) the face. I will fix it and recompile and get back to you, but that does appear to be the problem. Thanks man! > > When making displacements be sure to only select the face you want to turn into a displacement instead of selecting the whole brush. > > Also, the compile log window not responding is not an issue, it's just busy compiling to handle anything else (at a guess), the compile process will still continue just fine. Your main issue is that you have a leak, though. When you have a leak it will say "\*** leaked \***" in the compile log, as it does with yours, however it will usually also refer to the entity closest to the leak (eg "Entity light (-1607.69 -1094.12 -183.00) leaked!" (also note that the mentioned entity is not at all at fault, unless its origin is outside of the map)). Make sure you have at least one entity in the map else VBSP can't check for leaks and will always spit out "*** leaked***" even if there isn't a leak. Wow I have selected just the face as you said and it now looks even better! Before I was trying to sculpt the whole displaced block as a entire block now with just selecting one face it makes the rest of the faces besides the sculpted face disappear. Thanks for your help Fibbs!
    "risOsi"
    URL to post:

Embed

Share banner
Image URL
HTML embed code
BB embed code
Markdown embed code

Author

Mike C avatar
Mike C Joined 7y ago
Offline
3,434 points Ranked 2317th
Mike C
Sign up to access this!
Sign up to access this!
Sign up to access this!

Game

Sign up to access this!

Category

Share

  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • 0
  • 1.0k
  • 5
  • 7y

More from Submitter

WiPs by Submitter

More Help Threads