GMod9 does not join some servers

Attention Gamer! We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending DarknessDudeToB points.
  • Post: Give DarknessDudeToB your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Stop Lurking!

Join GameBanana

Already a Bananite? Login

Error: "This Steam account does not own this game. Please log into the correct account."

I need some help on this. I have recently downloaded Garry's Mod 9.0.4 since I can't buy GMod 10/11 yet. I installed, changed the GameInfoID to 215, and restarted Steam. I launched it sucessfully, able to play Single-Player mode. But when I went into Multiplayer mode, I couldn't join any servers due to this error: "ERROR: This Steam account does not own this game. Please log into the correct account." I cannot join any servers at all EXCEPT one of the FaceWAN Freebuild servers (Which I forgot the name of). I can't even create my own server. Me and my friend are having this problem, and we can't join any servers that have auctal players on it. I would like REAL help, and NOT stupid "Go buy Gmod 10/11" posts please.

Posts

  • 6y
    DarknessDudeToB avatar
    Member Joined 6y
    Any help would be appreciated please. I was recently playing again this morning too, and now I'm able to play on the Roleplay FaceWAN server, but nothing else still.
    Bananite
  • 6y
    Haxorfox avatar
    Haxorfox avatar Offline
    Member Joined 10y
    11,080 points Ranked 380th
    13 medals 1 rare
    • 6 years a member Medal icon
    • Became a Club Leader Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    I don't see why you can't buy Garry's mod.

    Anyhow, do you own Half-Life 2 and EP1?
    • Dumb x 1
    • Disagree x 1
    • wtf x 1
    • Rude x 1
    Greetings avatar
    Mantra
    Greetings
  • 6y
    DarknessDudeToB avatar
    Member Joined 6y
    I only have Portal First Slice, Portal 2, and Team Fortress 2. Though I don't see a reason why I can't run GMod 9 if I can run other mods perfectly fine.
    Bananite
  • 6y
    Kosai106 avatar
    Kosai106 avatar Offline
    Avenger Corp.™ Flag Affiliation: Avenger Corp.™
    Member Joined 10y
    Kosai106 avatar
    Kosai106
    Avenger Corp.™ Flag
    Avenger Corp.™
    Just buy GMod 10, it'll save you a lot of trouble with that outdated mod.
    Former super moderator avatar
    Mantra
    Former super moderator
  • 6y
    Haxorfox avatar
    Haxorfox avatar Offline
    Member Joined 10y
    11,080 points Ranked 380th
    13 medals 1 rare
    • 6 years a member Medal icon
    • Became a Club Leader Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    > **Posted by DarknessDudeToB**

    > I only have Portal First Slice, Portal 2, and Team Fortress 2. Though I don't see a reason why I can't run GMod 9 if I can run other mods perfectly fine.

    Yeah, you need Half-Life 2 at least. I recommend buying all Half-Life 2 episodes too.
    Greetings avatar
    Mantra
    Greetings

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

Send a Private Message to the submitter

Category

Stats

Posts
5
Views
4,783
Date Added
6y
bcp.crwdcntrl.net tracking pixel