Ads keep us online. Without them, we wouldn't exist. We don't have paywalls or sell mods - we never will. But every month we have large bills and running ads is our only way to cover them. Please consider unblocking us. Thank you from GameBanana <3

Game randomly Crashes:/

A Forum Thread for Left 4 Dead 2

No ads for members. Membership is 100% free. Sign up!
I installed the public demo yesterday, and for some reason the game crashes after reaching the first safe house:/ I have the game on recommended settings (High) and it works just fine until it suddenly crashes, so I don't think it's because of bad specs.
  • Processor: Intel ® Core ™ 2 Quad Core Processor Q8200 (2.33GHz, 1333MHz, 4MB cache)
  • Operating Systems: Genuine Windows Vista ® Home Premium SP2, 32-bit - Swedish
  • Graphics Cards: 512MB ATI ® Radeon ™ 4850
  • Memory: 3072 MB 1067 MHz DDR3 SDRAM with dual channels [3 x 1 024]
  • Hard Drives: 640 GB Serial ATA non Raid (7200 Rpm)
If you need more specific specs, tell me how to get them because I don't know how to^^ I do hope it's just being a bugged demo since I plan to buy this later on.
Sign up to access this!
  • NoZTriX avatar
    NoZTriX Joined 13y ago
    Offline
    access_time 10y

    Can't update the thread so I'm saying this here.

    I get no errors or anything when the game crashes as I would usually get when something else crashes. Also, In the list it says I have SP1, but I just forgot to change that so I'm actually having SP2.
    All I hear is noise
    URL to post:
  • Anti-Social avatar
    Anti-Social Joined 11y ago
    Offline
    581 points Ranked 44656th
    access_time 10y
    Did the update help? and you might wanna upgrade to SP2 BTW.
    ... avatar
    Mantra
    ...
    URL to post:
  • NoZTriX avatar
    NoZTriX Joined 13y ago
    Offline
    access_time 10y
    Posted by Anti-Social and you might wanna upgrade to SP2 BTW.
    Oh, I have SP2, I took this list from my profile and most have forgotten to change it^^ But which update, a steam update? Haven't got any recent one.
    All I hear is noise
    URL to post:
  • Anti-Social avatar
    Anti-Social Joined 11y ago
    Offline
    581 points Ranked 44656th
    access_time 10y
    Posted by NoZTriX
    Posted by Anti-Social and you might wanna upgrade to SP2 BTW.
    Oh, I have SP2, I took this list from my profile and most have forgotten to change it^^ But which update, a steam update? Haven't got any recent one.
    AH i remember there was a thread a couple days ago about this all you have to do is when l4d2 is running (main menu) go to task manager and right click on the .exe and and select either high or run as administrator. that what i told the other guy so i would try that and see!
    ... avatar
    Mantra
    ...
    URL to post:
  • NoZTriX avatar
    NoZTriX Joined 13y ago
    Offline
    access_time 10y
    Posted by Anti-Social
    Posted by NoZTriX
    Posted by Anti-Social and you might wanna upgrade to SP2 BTW.
    Oh, I have SP2, I took this list from my profile and most have forgotten to change it^^ But which update, a steam update? Haven't got any recent one.
    AH i remember there was a thread a couple days ago about this all you have to do is when l4d2 is running (main menu) go to task manager and right click on the .exe and and select either high or run as administrator. that what i told the other guy so i would try that and see!
    It worked by running it as administrator, but then I had to launch the exe through the common folder where it's located otherwise it says "This game is currently unavailable, please try again later". I also tried changing the compatibility mode to XP SP2 but didn't work either:/ I really hope it will work properly when/if I buy this game.
    All I hear is noise
    URL to post:
  • Live2bcool avatar
    Live2bcool Joined 12y ago
    Offline
    access_time 10y
    Posted by NoZTriX
    Posted by Anti-Social
    Posted by NoZTriX
    Posted by Anti-Social and you might wanna upgrade to SP2 BTW.
    Oh, I have SP2, I took this list from my profile and most have forgotten to change it^^ But which update, a steam update? Haven't got any recent one.
    AH i remember there was a thread a couple days ago about this all you have to do is when l4d2 is running (main menu) go to task manager and right click on the .exe and and select either high or run as administrator. that what i told the other guy so i would try that and see!
    It worked by running it as administrator, but then I had to launch the exe through the common folder where it's located otherwise it says "This game is currently unavailable, please try again later". I also tried changing the compatibility mode to XP SP2 but didn't work either:/ I really hope it will work properly when/if I buy this game.
    A long time ago I found a way to make it so Vista would run every program as Admin without asking or anything, I totally forgot how I did that...
    Novint Falcon User
    URL to post:
  • NoZTriX avatar
    NoZTriX Joined 13y ago
    Offline
    access_time 10y
    Posted by Live2bcool A long time ago I found a way to make it so Vista would run every program as Admin without asking or anything, I totally forgot how I did that...
    I know how to do that, but when I'm launching a program as admin, a window comes up and I have to allow/diss allow (or something) the program to be launched. But when launching the game through steam with the exe set to launch as admin I get this error "This game is currently unavailable, please try again later", I can still launch it by pressing the actual exe and not through the steam shortcut.
    All I hear is noise
    URL to post:
  • BrainZ avatar
    BrainZ username pic Joined 13y ago
    Offline
    16,269 points Ranked 352nd
    19 medals 1 legendary 1 rare
    • 10 years a member Medal icon
    • 6 years a member Medal icon
    • GAMEBANANA Spray Contest Entrant Medal icon
    • Became a Club Leader Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    access_time 10y
    Posted by Live2bcool A long time ago I found a way to make it so Vista would run every program as Admin without asking or anything, I totally forgot how I did that...
    You disabled UAC, which is highly recommended NOT to do.
    gone avatar
    Mantra
    gone
    URL to post:
  • Live2bcool avatar
    Live2bcool Joined 12y ago
    Offline
    access_time 10y
    Posted by BrainZ
    Posted by Live2bcool A long time ago I found a way to make it so Vista would run every program as Admin without asking or anything, I totally forgot how I did that...
    You disabled UAC, which is highly recommended NOT to do.
    Well that was on my old PC. :)
    Novint Falcon User
    URL to post:
  • octoplasma avatar
    octoplasma Joined 12y ago
    Offline
    34,006 points Ranked 134th
    13 medals 1 rare
    • 6 years a member Medal icon
    • Oddities Skinning Contest Entrant Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • Reached 25,000 Points Medal icon
    access_time 10y
    Its because you tried to have sex with it. and this, coming from you, is a major turn off. it just got turned off thats all. ONTOPIC: try updating your drivers. that worked for me.
    There's always money in the ba avatar
    Mantra
    There's always money in the ba
    URL to post:
  • NoZTriX avatar
    NoZTriX Joined 13y ago
    Offline
    access_time 10y
    Posted by octoplasma ONTOPIC: try updating your drivers. that worked for me.
    I went here to find an update for my drivers, downloaded it. But in the middle of the installation process, I got this error. I also tried to find an update by letting my vista do an online search but it didn't find any. Does these two things mean that I have the latest already?
    All I hear is noise
    URL to post:
  • octoplasma avatar
    octoplasma Joined 12y ago
    Offline
    34,006 points Ranked 134th
    13 medals 1 rare
    • 6 years a member Medal icon
    • Oddities Skinning Contest Entrant Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • Reached 25,000 Points Medal icon
    access_time 10y
    Maybe you entered in the wrongs specs in that tree. double check and try again. if you are 100% positive everything is correct, try downloading the driver from ATI's website. Oh and i just thought of something. You Have an ATI. this means your shadermodel is low (probably 2.0) this can cause problems. I upgraded my video card, because Fallout 3 required shader model 3.0 and would not even run. Try the above, and if that doesn't help, post your shader model number.
    There's always money in the ba avatar
    Mantra
    There's always money in the ba
    URL to post:
  • NoZTriX avatar
    NoZTriX Joined 13y ago
    Offline
    access_time 10y
    Posted by octoplasma Oh and i just thought of something. You Have an ATI. this means your shadermodel is low (probably 2.0) this can cause problems. I upgraded my video card, because Fallout 3 required shader model 3.0 and would not even run. Try the above, and if that doesn't help, post your shader model number.
    Where can I find such info then? Btw, a friend of mine has an older computer with lower specs, but he was able to play the game without any crashes.
    All I hear is noise
    URL to post:
  • octoplasma avatar
    octoplasma Joined 12y ago
    Offline
    34,006 points Ranked 134th
    13 medals 1 rare
    • 6 years a member Medal icon
    • Oddities Skinning Contest Entrant Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • Reached 25,000 Points Medal icon
    access_time 10y
    It usually says in print somewhere on the box. for some reason they don't write it big on the box. almost all ATI's have shadermodel 2.0. another possible error is that you dont have DX 10 or whatever they use now. find your shader model number and make sure you have DX10 and then report
    There's always money in the ba avatar
    Mantra
    There's always money in the ba
    URL to post:
  • NoZTriX avatar
    NoZTriX Joined 13y ago
    Offline
    access_time 10y
    Posted by octoplasma It usually says in print somewhere on the box. for some reason they don't write it big on the box. almost all ATI's have shadermodel 2.0. another possible error is that you dont have DX 10 or whatever they use now. find your shader model number and make sure you have DX10 and then report
    According to this, I have DX10.1 and shadermodel 4.1. Edit* Oh, it says DX10.1 support, but I'm 100% sure I have 10:)
    All I hear is noise
    URL to post:
  • BrainZ avatar
    BrainZ username pic Joined 13y ago
    Offline
    16,269 points Ranked 352nd
    19 medals 1 legendary 1 rare
    • 10 years a member Medal icon
    • 6 years a member Medal icon
    • GAMEBANANA Spray Contest Entrant Medal icon
    • Became a Club Leader Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    access_time 10y
    Posted by octoplasma It usually says in print somewhere on the box. for some reason they don't write it big on the box. almost all ATI's have shadermodel 2.0. another possible error is that you dont have DX 10 or whatever they use now. find your shader model number and make sure you have DX10 and then report
    L4D2 does not fully run on DX10 and does not require it to run either. If DX10 is available, L4D2 (and I believe L4D and TF2 too) uses merely some minor features of DX10 under the "DX 9.8 mode" like Valve calls it informally.
    gone avatar
    Mantra
    gone
    URL to post:

Embed

Share banner
Image URL
HTML embed code
BB embed code
Markdown embed code

Author

NoZTriX avatar
NoZTriX Joined 13y ago
Offline
NoZTriX
Sign up to access this!
Sign up to access this!
Sign up to access this!

Game

Sign up to access this!

Category

Share

  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • 0
  • 5.0k
  • 16
  • 10y
  • 10y

More from Submitter

WiPs by Submitter

More Help Threads