D3D error

Attention Gamer! We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending sKratch points.
  • Post: Give sKratch your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Stop Lurking!

Join GameBanana

Already a Bananite? Login

I have played L4D on this laptop before, but when I tried to launch it today, I got this error: Image and video hosting by TinyPic I have tried to add: -dxlevel 80 to the launch menu, but it didn't work. :< Help?

Posts

  • 8y
    Rootbeerz avatar
    Rootbeerz avatar Offline
    Member Joined 11y
    Did you try the steps before that?

    • Before updating your drivers, please visit Windows Update and make sure that you have all of the critical updates and the .NET framework installed.
    • If you get a Failed to create D3D device error and are using any of the above ATI Cards, please update your drivers to the latest version of Catalyst by visiting the ATI driver page.
    • If you use a Nvidia or any other type of video card, please visit the manufacturer's website for the latest video card drivers.
    Constructive Map Assesor avatar
    Mantra
    Constructive Map Assesor
  • 8y
    sKratch avatar
    sKratch Offline
    Member Joined 10y
    23,828 points Ranked 183rd
    10 medals 1 rare
    • 6 years a member Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • One month a member Medal icon
    Posted by Rootbeerz

    Did you try the steps before that?

    • Before updating your drivers, please visit Windows Update and make sure that you have all of the critical updates and the .NET framework installed.
    • If you get a Failed to create D3D device error and are using any of the above ATI Cards, please update your drivers to the latest version of Catalyst by visiting the ATI driver page.
    • If you use a Nvidia or any other type of video card, please visit the manufacturer's website for the latest video card drivers.


    No, but I found out, phew! :D

    How to fix the D3D error in L4D on a Lenevo laptop.

    edit: oh fuck, that didn't work...

    Edit 2: It automatically changes back to fullscreen "1" when I start L4D, what the fuck?

    Edit 3: I fixed it by adding "-window" to the launch command! :D
    Fuck. avatar
    Mantra
    Fuck.
  • 8y
    radicrains avatar
    radicrains Offline
    Member Joined 9y
    Posted by TwistedKiller

    Posted by Rootbeerz

    Did you try the steps before that?

    • Before updating your drivers, please visit Windows Update and make sure that you have all of the critical updates and the .NET framework installed.
    • If you get a Failed to create D3D device error and are using any of the above ATI Cards, please update your drivers to the latest version of Catalyst by visiting the ATI driver page.
    • If you use a Nvidia or any other type of video card, please visit the manufacturer's website for the latest video card drivers.


    No, but I found out, phew! :D

    How to fix the D3D error in L4D on a Lenevo laptop.

    edit: oh fuck, that didn't work...

    Edit 2: It automatically changes back to fullscreen "1" when I start L4D, what the fuck?

    Edit 3: I fixed it by adding "-window" to the launch command! :D


    What do you mean by launch command? I've been trying to find it. But im lost. :(
    Bananite
  • 8y
    sKratch avatar
    sKratch Offline
    Member Joined 10y
    23,828 points Ranked 183rd
    10 medals 1 rare
    • 6 years a member Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • Reached 7,500 Points Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • One month a member Medal icon
    Posted by radicrains

    Posted by TwistedKiller

    Posted by Rootbeerz

    Did you try the steps before that?

    • Before updating your drivers, please visit Windows Update and make sure that you have all of the critical updates and the .NET framework installed.
    • If you get a Failed to create D3D device error and are using any of the above ATI Cards, please update your drivers to the latest version of Catalyst by visiting the ATI driver page.
    • If you use a Nvidia or any other type of video card, please visit the manufacturer's website for the latest video card drivers.


    No, but I found out, phew! :D

    How to fix the D3D error in L4D on a Lenevo laptop.

    edit: oh fuck, that didn't work...

    Edit 2: It automatically changes back to fullscreen "1" when I start L4D, what the fuck?

    Edit 3: I fixed it by adding "-window" to the launch command! :D


    What do you mean by launch command? I've been trying to find it. But im lost. :(

    Go to Steam>My games and click mouse button 2 on the game that you wanna add the "-window" command to, then go to properties>Set launch options. :)
    Fuck. avatar
    Mantra
    Fuck.
  • 8y
    Metal-Head avatar
    Metal-Head Offline
    Member Joined 10y
    339 points Ranked 11850th
    8 medals 1 rare
    • 6 years a member Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    • 2 years a member Medal icon
    Posted by TwistedKiller

    Posted by radicrains

    Posted by TwistedKiller

    Posted by Rootbeerz

    Did you try the steps before that?

    • Before updating your drivers, please visit Windows Update and make sure that you have all of the critical updates and the .NET framework installed.
    • If you get a Failed to create D3D device error and are using any of the above ATI Cards, please update your drivers to the latest version of Catalyst by visiting the ATI driver page.
    • If you use a Nvidia or any other type of video card, please visit the manufacturer's website for the latest video card drivers.


    No, but I found out, phew! :D

    How to fix the D3D error in L4D on a Lenevo laptop.

    edit: oh fuck, that didn't work...

    Edit 2: It automatically changes back to fullscreen "1" when I start L4D, what the fuck?

    Edit 3: I fixed it by adding "-window" to the launch command! :D


    What do you mean by launch command? I've been trying to find it. But im lost. :(

    Go to Steam>My games and click mouse button 2 on the game that you wanna add the "-window" command to, then go to properties>Set launch options. :)

    Yo, I posted a thread about that in the L4D forums a while ago, and then I found out the command -windowed fixed it. I helped about 30-40 people that day lol.
    One Man Army avatar
    Mantra
    One Man Army

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

sKratch avatar
sKratch Offline
Member Joined 10y
23,828 points Ranked 183rd
10 medals 1 rare
  • 6 years a member Medal icon
  • Reached 1,000 Points Medal icon
  • Reached 2,500 Points Medal icon
  • Reached 7,500 Points Medal icon
  • 1 post awarded Exemplary Feedback Medal icon
  • One month a member Medal icon

sKratch
Send a Private Message to the submitter

Category

Stats

Posts
5
Views
9,410
Date Added
8y
Date Modified
8y
bcp.crwdcntrl.net tracking pixel