Ads keep us online. Without them, we wouldn't exist. We don't have paywalls or sell mods - we never will. But every month we have large bills and running ads is our only way to cover them. Please consider unblocking us. Thank you from GameBanana <3

Issue with compiling the game on Kade Engine - A Question for Friday Night Funkin'

Question Solved

This Question was answered and a solution was chosen.
Hi guys! i'm new with kade engine and compiling the game, but i have a problem for weeks.
When i open Windows Powershell and i type "lime test windows" it says:
"
source/PlayState.hx:11: characters 8-20 : Type not found : llua.Convert

source/PlayState.hx:12: characters 8-16 : Type not found : llua.Lua

source/PlayState.hx:13: characters 8-18 : Type not found : llua.State

source/PlayState.hx:14: characters 8-17 : Type not found : llua.LuaL

source/PlayState.hx:209: characters 24-29 : Type not found : State

source/StoryMenuState.hx:22: lines 22-399 : Defined in this class

C:/HaxeToolkit/haxe/lib/polymod/git/polymod/format/XMLMerge.hx:189: characters 10-23 : Warning : This typedef is deprecated in favor of haxe.xml.Access

C:/HaxeToolkit/haxe/lib/polymod/git/polymod/format/XMLMerge.hx:189: characters 30-43 : Warning : This typedef is deprecated in favor of haxe.xml.Access
"
I tried to look out for a tutorial or something that could help me with this issue, but i found nothing.
Does anyone know how to fix this? I would be really grateful!
  • BonkMaykr avatar
    BonkMaykr username pic Joined 2y ago
    Uberstylist Ripe Supporter
    it's over now
    297 points Ranked 61,603rd
    42 medals 5 legendary 7 rare
    • Became a Ripe Supporter Medal icon
    • Returned 5000 times Medal icon
    • Reached 100 subscribers Medal icon
    • Thanked 500 submitters Medal icon
    • Received thanks 500 times Medal icon
    • Thanked 50 submitters Medal icon
    BonkMaykr avatar
    BonkMaykr
    OldBanana Development Flag
    Affiliation
    OldBanana Development
    Uberstylist
    9mo 9mo
    I don't use Haxe, however, I'm pretty fluent in .NET programming. Allow me to explain what these errors mean so you can fix them.

    Type not found 
    You're probably missing some dependencies. Make sure the libraries and any external code you want to use is being linked to your mod's code correctly and that the compiler knows where to find all of it.

    Warning : This typedef is deprecated in favor of
    Deprecated just means that the feature is obsolete and they don't support it anymore, but it will still work. The compiler is just telling you that it recommends you use the newer methods because they're "better" (depending on who you ask) and are probably going to take over in a newer version. If something is deprecated, there's no need to worry. Unless you plan on updating your Haxe version soon, you don't need to fix those warnings.
    tom pls fix avatar
    Mantra
    tom pls fix
    URL to post: