Ads keep us online. Without them, we wouldn't exist. We don't have paywalls or sell mods - we never will. But every month we have large bills and running ads is our only way to cover them. Please consider unblocking us. Thank you from GameBanana <3

Sonic '06 Mod Manager - A Modding Tool for Sonic the Hedgehog (2006)

Updates

Version 3.41 1mo
  • BugFix Fixed the Height option on the Emulator page not saving your setting.
  • BugFix Fixed the custom accent colour reset button not restoring the correct default accent colour.
Version 3.4 1mo Removal Addition2 Adjustment Version 3.39 5mo BugFix Removal Version 3.38 6mo Addition BugFix Version 3.37 9mo BugFix2 Addition

A tool to handle mod copying and organisation for Sonic '06

A tool designed to make it easier to use and manage mods for Sonic '06 on the Xbox 360 and PlayStation 3.

For detailed documentation, see the Sonic '06 Mod Manager wiki on GitHub: https://github.com/Big-Endian-32/Sonic-06-Mod-Manager/wiki

If the game is missing sounds and visual effects, then ensure that you FULLY extracted your ISO (See here for instructions on that)
If certain patches cause an error upon installation, then ensure that you have Java installed (a system restart may be required), this is caused by certain patches using a Java script to decompile the game's Lua Bytecode for editing.
21-30 of 35
3
Pages
Go to page:
  • Does this work on original ps3? if so how do i get it to work? :D
    Bananite
    URL to post:
  • Batman Sonic avatar
    Batman Sonic Joined 4y ago
    Away
    9,484 points Ranked 834th
    25 medals 1 legendary 3 rare
    • Returned 5000 times Medal icon
    • Returned 1000 times Medal icon
    • 10 submissions featured Medal icon
    • Reached 50 subscribers Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    1y 1y
    There's a bug which disables every file (voice clips, music and etc) that was modified from mod name > xenon > sound.
    Is there any way to fix this or could be patched in the future?
    Hi, I mod Sonic games.
    URL to post:
  • TheKaijuGojira avatar
    TheKaijuGojira Joined 2y ago
    Offline
    153 points Ranked 79,743rd
    2y
    Will this work with Project 06 by ChaosX?
    Bananite
    URL to post:
  • mvp13 avatar
    mvp13 Joined 2y ago
    Offline
    759 points Ranked 46,921st
    11 medals 2 rare
    • Returned 1000 times Medal icon
    • Thanked 50 submitters Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • Thanked 5 submitters Medal icon
    2y
    I'm having an FPS issue. I'm not sure if it's because of a recent update, or something changed on my system... but if I enable VSync on the mod loader like I always have been, it locks my game to 30 FPS. If I uncheck VSync, the game runs at mostly 60 FPS, but goes above it on the menus (you see the characters breathing ridiculously fast, etc), and sometimes in mach speed sections you'll start moving ridiculously faster, getting to around 70 FPS in there sometimes. I'm on a 144hz monitor 

    Is it me, or the mod loader? I've always had the VSync option ticked, and confused why it's locking the game to 30 FPS now... 

    The only big thing I changed, was I stopped using a pirated version and manually installed my own copy of Sonic 06. I'm not sure that'd really change anything FPS wise, but just to throw that out there 
    Bananite
    URL to post:
  • Random question, I've noticed this a long time, but when I use the mod launcher to install mods Sonic can no longer do jump dash to break boxes, do flips of metal creates or even break wall and rock objects. I'm not sure what I have on thats disabling this, but it's been like that for at least a year
    Bananite
    URL to post:
  • mvp13 avatar
    mvp13 Joined 2y ago
    Offline
    759 points Ranked 46,921st
    11 medals 2 rare
    • Returned 1000 times Medal icon
    • Thanked 50 submitters Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    • 6 months a member Medal icon
    • Thanked 5 submitters Medal icon
    2y
    Hi, the Keep Entities After Restart patch crashes the game after certain segment switches. The one I was continually testing was Wave Ocean. Every time the Mach Speed segment started, the game would crash. It also happened during one of the Crisis City switches, but I forget which one (I think after the snowboard?) 

    Also, just a general question... the TGS Sonic Patch works during gameplay really well, but his finishing animation is pretty broken. He does the TGS animation, but he doesn't face the camera and he's really far away. Is there any way to fix that? In the interim, I went back to the TGS Sonic mod, that doesn't use TGS Sonic during the mach speed section, so his finishing animation is regular 
    Bananite
    URL to post:
  • Sasnic avatar
    Sasnic Joined 3y ago
    3,604 points Ranked 3,060th
    9 medals 1 rare
    • Returned 1000 times Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    • Returned 100 times Medal icon
    • 2 years a member Medal icon
    2y
    Don't work,it's all configured,emulator,mods directory,and the xex file,I click on Install and launch Sonic 06 but it don't open my emulator,even if I play Sonic 06 after doing it works
    bruh
    URL to post:
  • Batman Sonic avatar
    Batman Sonic Joined 4y ago
    Away
    9,484 points Ranked 834th
    25 medals 1 legendary 3 rare
    • Returned 5000 times Medal icon
    • Returned 1000 times Medal icon
    • 10 submissions featured Medal icon
    • Reached 50 subscribers Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    2y 2y
    Why everytime I click on Install mods and launch Sonic '06 
    it takes like 1 GB (or maybe 2 GB) space from my Local Disk (C:)?
    (I had 324 GB and now I have 301 GB)
    Hi, I mod Sonic games.
    URL to post:
  • Michael Blur avatar
    Michael Blur Joined 2y ago
    Offline
    2,230 points Ranked 21,884th
    8 medals 1 legendary 1 rare
    • Returned 5000 times Medal icon
    • Returned 1000 times Medal icon
    • Returned 100 times Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    2y
    I got an error with some "common.lub" file, which I don't have. How do fix it? 
    https://priscree.ru/img/23ef496dad3d0e.png
    Bananite
    URL to post:
  • Cant get this to work at all. No real clear good tutorials or instructions on what to do. 1-Click on any mod doesnt work or open the mod manager it just does nothing. I have 1-Click enabled in settings and save it but whenever i close out of the mod manager the 1-Click is disabled? And none of the mods show up at all when Im in the directory where I have to mods manually downloaded. Could really use help ftp is confusing as well trying to setup to a jailbroken ps3. Just trying to install mods to sonic 06 that i have on my console.
    Bananite
    URL to post: