My model has incorrect bounding box.

A Forum Thread for Goldsource Engine

I modelled a long fence in Blender, and made a qc file for it and it's one static animation, but it's bounding box seems to be a small cube at the origin point of the model.

I tried adding a bbox command to the QC file but that also didn't work, the bbox was still a cube at the center.

Doing "r_drawentities 4" showed the correct box, though.

Here's the blend, exported SMD of the blend file, and the 2 QCs (oh and the texture file):
http://www.mediafire.com/folder/qav1wcfwnropp/longfence
(BitPit file inserter doesn't seem to work).
Sign up to access this!

Replies

  • lvivtotoro avatar
    lvivtotoro Joined 5y ago
    Offline
    238 points Ranked 52556th
    1mo
    I made a video showcasing the issue.
    Youtuber and Programmer
    URL to post:
  • lvivtotoro avatar
    lvivtotoro Joined 5y ago
    Offline
    238 points Ranked 52556th
    1mo
    One more thing I noticed is that this happens for every single model I make, it's a general problem, not specific to the long fence posts.

    I'm using DoomMusic's StudioMDL if it helps: https://gamebanana.com/tools/6236
    Youtuber and Programmer
    URL to post:

Embed

Share banner
Image URL
HTML embed code
BB embed code
Markdown embed code

Author

lvivtotoro avatar
lvivtotoro Joined 5y ago
Offline
238 points Ranked 52556th

lvivtotoro
Sign up to access this!
Sign up to access this!
Sign up to access this!

Game

Sign up to access this!

Category

Share

  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • Share on Google+
  • 192 Views
  • 2 Posts
  • 1moSubmitted

More Other/Misc Threads

bcp.crwdcntrl.net tracking pixel