un-precise cycler_sprite placement

A Forum Thread for GoldSrc Engine

Greetings! We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending ~Mc3 points.
  • Post: Give ~Mc3 your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Stop Lurking!

Sign up

Already a Bananite? Login

i am making a map for cs 1.6, and i am trying to add a cycler_sprite on a corner to simulate bricks popping out of the wall( like CS:GO's de_inferno), but when i put the entity on the corner, for some reason, it shifts its position by 1 unit in a random direction(leaving a gap between the wall and the model), i know this is not just a display error on hammer because the models are also shifted in-game. Does anyone know why this happens?

Posts

  • 3y
    Danial Afridi avatar
    Danial Afridi avatar Offline
    Member Joined 5y
    52 medals 3 legendary 11 rare
    • Submitted 50 Gamefiles Medal icon
    • Submitted 15 Tools Medal icon
    • Submitted 60 Prefabs Medal icon
    • 50 posts awarded Exemplary Feedback Medal icon
    • Submitted 20 Gamefiles Medal icon
    • Submitted 15 Tutorials Medal icon
    Cycler_Sprite (and a few other entities) tend to not move properly. They are not moved as you move solids/brushes. It's a bit annoying and mostly results in improper placements of models.

    However, this is not a problem on your side, it happens with everyone, it's Hammer itself. It's usually because of the model units are different than the Hammer's units. Probably because Hammer and Modelling application have different grid lines.

    Therefore, when you create a model, it doesn't align properly in Hammer's grid lines, because the application used to make model had different grid lines.

    However, you can adjust and place your model properly (not exact with the grid lines though). Concentrating and trying to get it aligned as you want can help, it's a bit time taking though.

    First of all, try to smaller the grid (to 1 or what seems comfortable for you). That's the third option in the Maps view bar (check screenshot).

    Now, you can move your model (Cycler_Sprite) more properly the way you want and it won't displace itself that much.

    What I suggest is to consider using those arrows (white squares around the model when selected) for more precise movement of the model. Just note that a few units inaccuracy won't cause trouble/issue unless you're really wanting to have the exact grid lines matching (which won't happen in most cases, unfortunately).

    It means you can let the model to overlay the wall/brush/etc. as this won't be noticed nor cause any issue.

    Hope that helps you.

    Let me know if you're still having any problem.
    • Helpful x 1
    • Thanks x 1
  • 3y
    ~Mc3 avatar
    ~Mc3 avatar Offline
    Life Tree Flag Affiliation: Life Tree
    Member Joined 3y
    1,206 points Ranked 3971st
    20 medals 1 rare
    • Returned 1000 times Medal icon
    • GameBanana’s Christmas Giveaway 2014 Day Fifteen Winner! Medal icon
    • 11-15 Entries! GameBanana’s Christmas Giveaway 2014 Medal icon
    • Winter Worlds Mapping Contest Entrant Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • One month a member Medal icon
    ~Mc3 avatar
    ~Mc3
    Life Tree Flag
    Life Tree
    > **Posted by PKGamerX**
    >
    > Cycler_Sprite (and a few other entities) tend to not move properly. They are not moved as you move solids/brushes. It's a bit annoying and mostly results in improper placements of models.
    >
    > However, this is not a problem on your side, it happens with everyone, it's Hammer itself. It's usually because of the model units are different than the Hammer's units. Probably because Hammer and Modelling application have different grid lines.

    > Therefore, when you create a model, it doesn't align properly in Hammer's grid lines, because the application used to make model had different grid lines.
    >
    > However, you can adjust and place your model properly (not exact with the grid lines though). Concentrating and trying to get it aligned as you want can help, it's a bit time taking though.
    >
    > First of all, try to smaller the grid (to 1 or what seems comfortable for you). That's the third option in the Maps view bar (check screenshot).
    >
    > Now, you can move your model (Cycler_Sprite) more properly the way you want and it won't displace itself that much.
    >
    > What I suggest is to consider using those arrows (white squares around the model when selected) for more precise movement of the model. Just note that a few units inaccuracy won't cause trouble/issue unless you're really wanting to have the exact grid lines matching (which won't happen in most cases, unfortunately).

    > It means you can let the model to overlay the wall/brush/etc. as this won't be noticed nor cause any issue.
    >
    > Hope that helps you.

    > Let me know if you're still having any problem.

    Thanks a lot dude, you really helped me, now my models are placed nice and precisely.
    Be nice, darling. avatar
    Mantra
    Be nice, darling.

Embed

Share banner
Image URL:
HTML embed code:
BB embed code:
Markdown embed code:

Submitter

~Mc3 avatar
~Mc3 avatar Offline
Life Tree Flag Affiliation: Life Tree
Member Joined 3y
1,206 points Ranked 3971st
20 medals 1 rare
  • Returned 1000 times Medal icon
  • GameBanana’s Christmas Giveaway 2014 Day Fifteen Winner! Medal icon
  • 11-15 Entries! GameBanana’s Christmas Giveaway 2014 Medal icon
  • Winter Worlds Mapping Contest Entrant Medal icon
  • 1 post awarded Exemplary Feedback Medal icon
  • One month a member Medal icon

~Mc3 avatar
~Mc3
Life Tree Flag
Life Tree
Sign up to access this!
Sign up to access this!
Sign up to access this!
Sign up to access this!

Category

Attributes

Stats

Posts
2
Views
1,550
Date Added
3y
Date Modified
3y
bcp.crwdcntrl.net tracking pixel