Ads keep us online. Without them, we wouldn't exist. We don't have paywalls or sell mods - we never will. But every month we have large bills and running ads is our only way to cover them. Please consider unblocking us. Thank you from GameBanana <3

Set a program to run on priority?

A Forum Thread for GameBanana

Alright, so for some reason, when I play CS:S, I have to launch the game and open up task manager. I have to find HL2, and I have to set the priority to "Low". I do this every time I launch the game, and I'm not sure why. I have: windows 7 64 bit ATI Radeon 4870 AMD Athlon 3700+ Single core processor 2GB RAM Alright, so my first question: Why do I have to set it to low priority? My guess is that I need more ram, and a better processor (in the process of getting a 6 core processor from AMD >:D), so am I right? And my second question, how do i set it to where it ALWAYS runs on LOW priority? I can't do it in the launch options, or any other ways I've tried :( HELP!!! (Also it doesn't let me run HL2.exe in compatibility mode :( )

Replies

Sign up to access this!
  • Kapanga avatar
    Kapanga Joined 11y ago
    Offline
    924 points Ranked 41160th
    9 medals 1 rare
    • 6 years a member Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • 5 posts awarded Exemplary Feedback Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    access_time 9y
    The proccessor is bad. Windows doesn't remember those settings, I remember a utility that does so, but I don't remember its name ATM.
    The last hero of the world... avatar
    Mantra
    The last hero of the world...
    URL to post:
  • Judo avatar
    Judo Joined 13y ago
    Offline
    314,415 points Ranked 8th
    18 medals 4 rare
    • Reached 75,000 Points Medal icon
    • Reached 200,000 Points Medal icon
    • 6 years a member Medal icon
    • Returned 1000 times Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    Judo Technical Expert
    access_time 9y
    Why do I have to set it to low priority?
    Because Windows sucks. No seriously, it's a kernel bug. At least, that's by and far the most likely cause. Without thoroughly explaining the concept of threading it's hard to explain why that's so, but even then... setting the priority to low fixes things? I can understand setting it to high, but low.... In any case, getting a new processor or RAM won't fix the problem. More powerful hardware may make the problem less noticeable, but it won't fix it. As for your second question, see here.
    ?????? avatar
    Mantra
    ??????
    URL to post:

Embed

menu
Share banner
Image URL
HTML embed code
BB embed code
Markdown embed code

Author

[F]ox avatar
[F]ox Joined 12y ago
Offline
289 points Ranked 50912th
[F]ox
Sign up to access this!
Sign up to access this!
Sign up to access this!

Game

Sign up to access this!

Category

Share

  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • favorite 0
  • remove_red_eye 924
  • mode_comment 2
  • access_time 9y

More from Submitter

menu

WiPs by Submitter

menu

More General Discussion Threads