Ads keep us online. Without them, we wouldn't exist. We don't have paywalls or sell mods - we never will. But every month we have large bills and running ads is our only way to cover them. Please consider unblocking us. Thank you from GameBanana <3

.cfg issues!?

A Question for Garry's Mod

No ads for members. Membership is 100% free. Sign up!

Question Answered but Unsolved

This Question has been answered but no solution has been chosen. You can still post your own answer to help the submitter.

I screwed up now.

So one day in TF2 (See edit below) I tried messing with my settings and screwed up. I didn't get to save my old bindings, and to make matters worse, I somehow messed up how my .cfg files would work for any other game (see: Gmod). I recall trying to copy Team Fortress Forever's .cfg file and it made it work for the time being, but it doesn't work as intended still.

The situation as I know is as follows (And I've already typed this up twice only to end up WIPING it all):
  • Nothing saves unless I use the console to temporarily override a binding. Any other setting doesn't save at all since clicking OK or APPLY will go back to crap.
  • Gmod is worse somehow-- It currently wipes to a blank state, where I can't open the spawn or context menus, among other things.
  • This has been going on for over 3 years, or longer.
  • I've tried looking into each game's .cfg files (userconfig, the default ones, etc.) and editing them there, but no luck.
  • I couldn't find anywhere else online with this bad of an issue as mine, with the difference here that it isn't just TF2 that's screwed up.

HOW do I even begin fixing this?! Please help me!

Edit 1: I think I got a solution from a fellow Discord user for my tf2 binds. The Gmod problem is still an unknown situation however, so at this point I only need Gmod help.
Sign up to access this!
  • MEDWINN avatar
    MEDWINN Joined 11mo ago
    access_time 3mo
    well dude u could go to properties on steam and verify game files. Steam will reinstall files they find unworthy.
    URL to post:
  • Thunderkeil avatar
    Thunderkeil username pic Joined 6y ago
    14,359 points Ranked 407th
    31 medals 3 legendary 6 rare
    • 15+ Entries! GameBanana’s Christmas Giveaway 2016 Medal icon
    • Returned 5000 times Medal icon
    • 15+ Entries! GameBanana’s Christmas Giveaway 2017 Medal icon
    • GameBanana’s Christmas Giveaway 2015 Day Three Winner! Medal icon
    • 8-14 Entries! GameBanana’s Christmas Giveaway 2015 Medal icon
    • Returned 1000 times Medal icon
    access_time 3mo
    • Nothing saves unless I use the console to temporarily override a binding.

    Check to see if they're set to read-only?
    But yea honestly just verify/reinstall, it should take mere minutes for these games. Idk how steam deals w workshop content for uninstalled titles though, maybe copy the files over beforehand so you can keep those around if it's it's a lot

    Frankly the lack of certain buttons in gmod seems pretty darn obvious if you replaced its cfg with tf2's, since tf2 doesn't have those buttons
    URL to post:
  • kizuati avatar
    kizuati Joined 5mo ago
    612 points Ranked 44154th
    13 medals 2 legendary 2 rare
    • 2019 Top Contributor Medal icon
    • Became a Ripe Supporter Medal icon
    • 10 submissions featured Medal icon
    • Returned 1000 times Medal icon
    • Submission featured Medal icon
    • Returned 100 times Medal icon
    access_time 3mo
    Hey,a radical solution but hey:
    Your config overrides GMod's keys - that's obvious.
    Delete your config and do a factory reset of gmod - there is .bat file in its directory - it should help get the binds back.
    URL to post:


Share banner
Image URL
HTML embed code
BB embed code
Markdown embed code


QuazzleTheQaz avatar
QuazzleTheQaz Joined 4y ago
245 points Ranked 53684th
Sign up to access this!
Sign up to access this!
Sign up to access this!


Sign up to access this!



  • Share on Reddit
  • Share on Twitter
  • Share on Facebook
  • 0
  • 194
  • 4
  • 3mo
  • 3mo

More Other/Misc Questions