Torch

A Map Prefab for Counter-Strike: Source

Hey, you! We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending Fibbs points.
  • Post: Give Fibbs your thoughts on this Prefab.
  • Vote: Help Fibbs win the Monthly Awards.
  • Rate: Give this Prefab a rating out of 10.
  • Flag: Alert moderators and warn members of a problem with this Prefab.
  • Watch: Get notified when this Prefab is updated.
Mascot

Resistance is futile...

Sign up

Already a Bananite? Login

A torch prop with separate parts and LODs.

*Fixed the materials. Dropped them into the wrong folder. Sorry about that! Info:
Torch with a ...mount? Can't remember what the thing holding it is called. There are 6 models:
Torchbr
TorchMountbr
TorchwithMountbr
and the same again but with LODs (../models/fibbs/torch/lods) "Torch" is the torch by itself, "TorchMount" is just the mount and "TorchwithMount" is both of them in one. They all have proper pivot points and align to the grid well so it isn't a pain fitting them to walls. I suppose these don't really need LODs but I've been wanted to try them out for a while, so I thought why not? There are 4 Levels Of Detail including the reference. Besides that I "cheated" somewhat in creating them using the MultiRes modifier in 3DS Max I think they still look pretty good, and you don't notice how bad they look from the distances they appear in anyway. Textures are 512x512 for the torch and 256x256 for the mount which are a little big for what it is. They also both have a normal map and specular map which look quite nice, although the wood is overdone I think (and a little too shiny perhaps). Anyway tri count:
(ref, lod1, lod2, lod3) Torch:
302, 165, 73, 4 TorchMount:
286, 214, 70, 26 TorchwithMount:
588, 402, 251, 54 They also have accurate collision models (screenshot 4). Installation:
Extract to your cstrike folder. If you don't want the versions with LODs then delete the LODs folder in ../cstrike/models/fibbs/torch. If you only want the LOD versions then delete everything in ../cstrike/models/fibbs/torch EXCEPT the LODs folder. Usage:
To be used as a prop\_static only. You could use prop\_physics\_override if you want it to move.
Mirror: Click to Download

Download

Posts

  • 1
  • 2
  • 4y
    kubedawg avatar
    kubedawg Offline
    Member Joined 10y
    372 points Ranked 11086th
    I finally got it fixed. I had to dl CrazyBump app and the VTF plugin for Photoshop to recreate the bump map for the model but it works as intended now. I know FF uses and older version of the SDK but I figured since this was made a few years ago that CS:S was still on the same SDK base at the time this was created. Anyway, thanks for all your help. This will look great in my map.
    Nade Whore
  • 4y
    Fibbs avatar
    Fibbs avatar Offline
    Member Joined 10y
    29,089 points Ranked 147th
    23 medals 1 rare
    • 6 years a member Medal icon
    • Prefaber of the Month, June 2012 Medal icon
    • MiPper of the Month, June 2012 Medal icon
    • Prefaber of the Month, March 2013 Medal icon
    • Texturer of the Month, July 2014 Medal icon
    • Became a Studio Leader Medal icon
    > **Posted by kubedawg**

    > I've reinstalled this model numerous times. I think it may be a problem with your VTF file for the bumpmaps because the file path is the same folder for both the regular texture and the bump map texture and the regular texture shows up in game just fine. Did you use VTF Editor to make the bump maps because I've done some research that said VTF Editor works creating bump maps only about half the time.

    I used Nvidia's Normal Map tool for Photoshop and saved it directly from Photoshop with a plugin. I've done it this way for a long time without any issues and so have many other people. Quite a few other people have also already used this model in CS:S maps without issue. I think the issue may be something to do with FF being on an older version of the engine. This was made for Source 2007 and onwards so I'm not sure if it might be a problem with some of the differences of the 2006 engine (possibly an issue with the way the envmap mask is loaded with $normalmapalphaenvmapmask). Anyway, you might have more luck talking to someone more experienced with FF modding (if it's worth it) as I've no idea what else to suggest, sorry.
  • 4y
    kubedawg avatar
    kubedawg Offline
    Member Joined 10y
    372 points Ranked 11086th
    I've reinstalled this model numerous times. I think it may be a problem with your VTF file for the bumpmaps because the file path is the same folder for both the regular texture and the bump map texture and the regular texture shows up in game just fine. Did you use VTF Editor to make the bump maps because I've done some research that said VTF Editor works creating bump maps only about half the time.
    Nade Whore
  • 4y
    Fibbs avatar
    Fibbs avatar Offline
    Member Joined 10y
    29,089 points Ranked 147th
    23 medals 1 rare
    • 6 years a member Medal icon
    • Prefaber of the Month, June 2012 Medal icon
    • MiPper of the Month, June 2012 Medal icon
    • Prefaber of the Month, March 2013 Medal icon
    • Texturer of the Month, July 2014 Medal icon
    • Became a Studio Leader Medal icon
    > **Posted by kubedawg**

    > Ok more on this issue, I did see an error when I ran my map with these models: Error reading in file "materials/models/Fibbs/Torch\_n.vtf" - So what I did was go into the VMT file and change the path for the bump map to materials/models/Fibbs instead of just models/Fibbs. This got rid of the error in console but the bumpmap material is still not showing. I built my cubemaps and that did not fix the issue either. This issue is slowly becoming more of a hassle than it's worth so I might just try locating a different model for my torches which is too bad because this is certainly the best looking one so far.

    If you look at the Torch VMT in notepad you'll see that the bumpmap line references 'models/Fibbs/Torch\_n' (all paths start relative to the materials folder, so this is ../base game folder/materials/models/Fibbs/Torch\_n.vtf). Make sure you put Torch\_n.vtf along with all the other materials/textures in the ../materials/models/Fibbs/ folder and it should find them.
  • 4y
    kubedawg avatar
    kubedawg Offline
    Member Joined 10y
    372 points Ranked 11086th
    Ok more on this issue, I did see an error when I ran my map with these models: Error reading in file "materials/models/Fibbs/Torch_n.vtf" - So what I did was go into the VMT file and change the path for the bump map to materials/models/Fibbs instead of just models/Fibbs. This got rid of the error in console but the bumpmap material is still not showing. I built my cubemaps and that did not fix the issue either. This issue is slowly becoming more of a hassle than it's worth so I might just try locating a different model for my torches which is too bad because this is certainly the best looking one so far.
    Nade Whore
  • 4y
    Fibbs avatar
    Fibbs avatar Offline
    Member Joined 10y
    29,089 points Ranked 147th
    23 medals 1 rare
    • 6 years a member Medal icon
    • Prefaber of the Month, June 2012 Medal icon
    • MiPper of the Month, June 2012 Medal icon
    • Prefaber of the Month, March 2013 Medal icon
    • Texturer of the Month, July 2014 Medal icon
    • Became a Studio Leader Medal icon
    > **Posted by kubedawg**

    > I think they may be missing the _n vtf files. In the VMT files, it shows: $bumpmap "models/Fibbs/Torch_n"
    > but those vtf files for the Torch/Mount are not in the included files.

    Are you sure you haven't misplaced them? They're in the archive in the download.
  • 4y
    kubedawg avatar
    kubedawg Offline
    Member Joined 10y
    372 points Ranked 11086th
    I think they may be missing the _n vtf files. In the VMT files, it shows: $bumpmap "models/Fibbs/Torch_n"
    but those vtf files for the Torch/Mount are not in the included files.
    Nade Whore
  • 4y
    Fibbs avatar
    Fibbs avatar Offline
    Member Joined 10y
    29,089 points Ranked 147th
    23 medals 1 rare
    • 6 years a member Medal icon
    • Prefaber of the Month, June 2012 Medal icon
    • MiPper of the Month, June 2012 Medal icon
    • Prefaber of the Month, March 2013 Medal icon
    • Texturer of the Month, July 2014 Medal icon
    • Became a Studio Leader Medal icon
    > **Posted by kubedawg**

    > Ok, thanks for your reply. I redownloaded and it didn't change anything. The game I'm installing it on is called Fortress Forever so idk if that has something to do with it but it's a Source SDK 2006 game.

    It may be an issue with VTF versions. If you have/get VTFEdit, open one of FF's VTF files in that and check what the version is in the Info tab. CS:S's VTF version is 7.2 so if it's different then you'll need to re-create the Torch VTFs. You can do that by opening them in VTFEdit, exporting to TGA, importing the TGA and selecting the correct version in the Advanced tab of the import options window that'll pop up, then just save it over the old VTF. That's the only thing I can think of at the moment, since it seems to be loading the models fine but it looks like it can't load the textures properly.
  • 4y
    kubedawg avatar
    kubedawg Offline
    Member Joined 10y
    372 points Ranked 11086th
    Ok, thanks for your reply. I redownloaded and it didn't change anything. The game I'm installing it on is called Fortress Forever so idk if that has something to do with it but it's a Source SDK 2006 game.
    Nade Whore
  • 4y
    Fibbs avatar
    Fibbs avatar Offline
    Member Joined 10y
    29,089 points Ranked 147th
    23 medals 1 rare
    • 6 years a member Medal icon
    • Prefaber of the Month, June 2012 Medal icon
    • MiPper of the Month, June 2012 Medal icon
    • Prefaber of the Month, March 2013 Medal icon
    • Texturer of the Month, July 2014 Medal icon
    • Became a Studio Leader Medal icon
    > **Posted by kubedawg**

    > -snip-

    The file in one of the mirrors didn't seem to update when I fixed the materials ages ago. I reuploaded the file anyway and fixed the mirror to my site (bottom of the description). Thanks for notifying me.

    As for your issue, I have no idea. You should just be able to extract the folders in the archive directly into your game folder (cstrike) for it to be picked up by Hammer (although I may need to update that to the 'custom' folder since the steampipe update, in order to see it in-game). I just tested it myself as prop\_static and dynamic and both showed up just fine. Not sure what to say really. Try the files from my mirror (even though they should be the same).
  • 1
  • 2

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Credits

Key Authors
Fibbs
Everything

Submitter

Fibbs avatar
Fibbs avatar Offline
Member Joined 10y
29,089 points Ranked 147th
23 medals 1 rare
  • 6 years a member Medal icon
  • Prefaber of the Month, June 2012 Medal icon
  • MiPper of the Month, June 2012 Medal icon
  • Prefaber of the Month, March 2013 Medal icon
  • Texturer of the Month, July 2014 Medal icon
  • Became a Studio Leader Medal icon

Fibbs avatar
Fibbs

Creator
Sign up to access this!
Sign up to access this!
Sign up to access this!
Sign up to access this!

Attributes

Stats

Posts
18
Views
5,933
Downloads
1,493
Date Added
7y
Date Modified
2y

Scores

92 bScore
10 Rating

4 voters

Sign up to access this!

Development Info

Notes
3DS Max, Photoshop and GUIstudiomdl (for convenience) were used to make this.
bcp.crwdcntrl.net tracking pixel