Source Engine Icon SOURCE Thread

Missing faces? I need help

Greetings! We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending Matias-TM points.
  • Post: Give Matias-TM your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Resistance is futile...

Sign up

Already a Bananite? Login

Hello, I am starting in 3D modelling for Source Engine. But i don't know why this happens. I am using Blender 2.78 and i made a wood chair. But i compiled in GUIStudioMDL, I see in the Model Viewer and the model has missing faces. I'll leave you 2 screenshots.





Many will tell me I'm stupid. But I do not understand. I need help. Thanks.

Posts

  • 6mo
    [PRince_4] Sharma avatar
    IND Industry! Flag Affiliation: IND Industry!
    Member Joined 11mo
    4,072 points Ranked 1093rd
    21 medals 4 rare
    • 10 submissions featured Medal icon
    • Received thanks 50 times Medal icon
    • Thanked 50 submitters Medal icon
    • 8-14 Entries! GameBanana’s Christmas Giveaway 2016 Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    [PRince_4] Sharma IND Industry! Flag
    IND Industry!
    Report post
    Put the Files here and i'll see..
    And maybe you need to use "Flip Normals" On those Faces..
    Slicin' My Way 2 TOP! avatar
    Mantra
    Slicin' My Way 2 TOP!
  • 6mo
    Matias-TM avatar
    Matias-TM avatar Not here...
    Member Joined 3y
    877 points Ranked 5135th
    16 medals 2 rare
    • Returned 1000 times Medal icon
    • 10 submissions featured Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    • Submitted 20 Threads Medal icon
    Report post
    Posted by [PRince_4] Sharma

    Put the Files here and i'll see..
    And maybe you need to use "Flip Normals" On those Faces..
    Here is all the models, textures and the project.

    Link
    Mapper avatar
    Mantra
    Mapper
  • 6mo
    [PRince_4] Sharma avatar
    IND Industry! Flag Affiliation: IND Industry!
    Member Joined 11mo
    4,072 points Ranked 1093rd
    21 medals 4 rare
    • 10 submissions featured Medal icon
    • Received thanks 50 times Medal icon
    • Thanked 50 submitters Medal icon
    • 8-14 Entries! GameBanana’s Christmas Giveaway 2016 Medal icon
    • One month a member Medal icon
    • Returned 100 times Medal icon
    [PRince_4] Sharma IND Industry! Flag
    IND Industry!
    Report post
    Posted by Matias-TM

    Posted by [PRince_4] Sharma

    Put the Files here and i'll see..
    And maybe you need to use "Flip Normals" On those Faces..
    Here is all the models, textures and the project.

    Link
    Alright, i'll take a look but the Problem is that i don't have my Lap today so i'll just download Blender and see if there's somethin' i can do..


    Edit:
    Download Speed is Like 30 Kbps :(

    Slicin' My Way 2 TOP! avatar
    Mantra
    Slicin' My Way 2 TOP!
  • 6mo
    wohSiesta avatar
    wohSiesta avatar Toasted
    Apocalyptic Flag Affiliation: Apocalyptic
    Moderator Joined 6y
    38,536 points Ranked 107th
    54 medals 1 legendary 10 rare
    • Returned 5000 times Medal icon
    • 2nd Place - Winter Textures Contest Medal icon
    • 2nd Place - Texture Pack Contest Medal icon
    • Submitted 30 Textures Medal icon
    • 2nd Place - 2015 Uberstyles Contest! Medal icon
    • Thanked 50 submitters Medal icon
    wohSiesta avatar
    wohSiesta
    Apocalyptic Flag
    Apocalyptic
    Mmm... toasty!
    Report post
    Fixed it for you
    http://files.gamebanana.com/bitpit/wood_chair.blend

    There are two main ways to check If the normals are facing in the right direction.

    Press the button "n" to make the right side panel appear.
    There you'll find the Backface Culling

    If you enable it. You will get something like this:

    As you can see, there are a few quads facing the wrong way.

    The second and prefered way is also located in the right side panel.

    After you press it you'll get this effect

    These little spikes represent the directions the sides are facing.

    Now, onto your problem!

    In edite mode (after you select an object and press "TAB" button on it) press the "a" button (to select every vertex) Should look like this.

    Then you'll have to press the CTRL+N button combination (while everything is selected).
    In most cases this should automatically fix the issue for you.

    If the normals turned out to be facing the wrong way, like so.

    Ther is a button you'll need to press to flip all normals in the opposit direction.

    This check mark appears on the left side of the Tools panel, after you pressed the previously mentioned CTRL+N combination to flip the normals. 

    That's it in a nutshell.
    • Thanks x 1
    • Helpful x 1
    • Informative x 1
    • Smart x 1
    Sad Sarcasm

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

Matias-TM avatar
Matias-TM avatar Not here...
Member Joined 3y
877 points Ranked 5135th
16 medals 2 rare
  • Returned 1000 times Medal icon
  • 10 submissions featured Medal icon
  • One month a member Medal icon
  • 6 months a member Medal icon
  • 1 year a member Medal icon
  • Submitted 20 Threads Medal icon

Matias-TM avatar
Matias-TM
Send a Private Message to the submitter

Category

Stats

Posts
4
Views
346
Date Added
6mo
Date Modified
2mo