Tf2 crashes on main menu

Hey, you! We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending Ti|Nith points.
  • Post: Give Ti|Nith your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Resistance is futile...

Join GameBanana

Already a Bananite? Login

Tf2 crashes on main menu

This is getting on my nerves.

Hello, I wanted to play TF2 just now but it seems that everytime I start the game it freezes in the very exact moment when the menu shows up, repeatedly playing the very fist second of the "you have new items" sound for a few seconds, then Win7 tells me the program is not responding.

I've already tried verifying the game files (no errors) and disabling some mods (didn't do anything as well). Please help me, fellas.

Comments

  • Secksy Medic avatar
    Member Joined 5 years ago
    864 points Ranked 4756th
    Report post
    3 years ago:
    I've had the same problem!
    Ze Charge iz Vready
  • Ti|Nith avatar
    Ti|Nith Offline
    Member Joined 4 years ago
    4,859 points Ranked 863rd
    10 medals 0 legendary, 0 rare
    • Gamefiler of the Month, June 2014 Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    Report post
    3 years ago:
    Posted by Secksy Medic

    I've had the same problem!

    You "had" the same problem? Did you fix it?
    Is that my blood?
  • Uncle dolan avatar
    Member Joined 3 years ago
    192 points Ranked 15608th
    Report post
    3 years ago:
    It happened to me a few days ago after this destroyed it. http://tf2.gamebanana.com/guis/23545 It did the same thing to me but i deleted it and now swhen i try to enter a server and a bot server (self made, like when you go to tutorial and stuff) it crashes during resources..

    Turns out im missing a resourses folder because i deleted it and tf2 wont restore it either...
    BANNED
  • DBlake avatar
    DBlake Offline
    Member Joined 4 years ago
    447 points Ranked 8341st
    9 medals 0 legendary, 0 rare
    • Reached 1,000 Points Medal icon
    • One month a member Medal icon
    • 6 months a member Medal icon
    • 1 year a member Medal icon
    • 2 years a member Medal icon
    • Received thanks 5 times Medal icon
    Report post
    3 years ago:
    Posted by LordCowtopianTNT

    It happened to me a few days ago after this a facepunch colored menu screen destroyed it. It did the same thing to me but i deleted it and now swhen i try to enter a server and a bot server (self made, like when you go to tutorial and stuff) it crashes during resources..

    Turns out im missing a resourses folder because i deleted it and tf2 wont restore it either...

    You're not supposed to add things directly to the main TF2 folder anymore. You need to use the custom directory for this.
    Wish I could think of a title.
  • Uncle dolan avatar
    Member Joined 3 years ago
    192 points Ranked 15608th
    Report post
    3 years ago:
    Posted by DBlake

    Posted by LordCowtopianTNT

    It happened to me a few days ago after this a facepunch colored menu screen destroyed it. It did the same thing to me but i deleted it and now swhen i try to enter a server and a bot server (self made, like when you go to tutorial and stuff) it crashes during resources..

    Turns out im missing a resourses folder because i deleted it and tf2 wont restore it either...

    You're not supposed to add things directly to the main TF2 folder anymore. You need to use the custom directory for this.

    I do, I put vpks into the custom folder and non vpks into

    "my_custom_folder"
    BANNED
  • Secksy Medic avatar
    Member Joined 5 years ago
    864 points Ranked 4756th
    Report post
    3 years ago:
    Posted by Ti|Nith

    Posted by Secksy Medic

    I've had the same problem!

    You "had" the same problem? Did you fix it?

    Well I have no idea I'm waiting for my ticket to be answerd from steam support.
    Ze Charge iz Vready
  • TheNotFriendlySpy avatar
    Member Joined 4 years ago
    472 points Ranked 7937th
    Report post
    3 years ago:
    im having the same problem. the last time when this happened, i re-installed my windows and it was fixed, i dont know if theres another way to fix it. if someone knows another way to fix it, plz tell us im breaking my computer on the middle trying to fix this sh*t.
    Bananite

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

Ti|Nith avatar
Ti|Nith Offline
Member Joined 4 years ago
4,859 points Ranked 863rd
10 medals 0 legendary, 0 rare
  • Gamefiler of the Month, June 2014 Medal icon
  • Reached 1,000 Points Medal icon
  • Reached 2,500 Points Medal icon
  • 1 post awarded Exemplary Feedback Medal icon
  • One month a member Medal icon
  • 6 months a member Medal icon

Ti|Nith
Send a Private Message to the submitter

Game

Category

Stats

Posts
7
Views
2,684
Date Added
3 years ago
Jun 22 2013 @ 6:51pm UTC

More Threads from Ti|Nith