Team Fortress 2 Icon TF2 Thread

HL2.EXE has stopped working

Hey Bro: We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending Apple3.14 points.
  • Post: Give Apple3.14 your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Interested?

Sign up

Already a Bananite? Login

Crashes to desktop with the error message in the title.

I'm getting CTDs pretty much every time I join into my favorite 2fort server. I also experienced the crashes in other servers. When it happens the game just freezes and refuses to respond in anyway, to the point where I have to alt tab out of it or start the task manager. When I get back to my desktop via one of the aforementioned methods I find a dialog box with the error message "HL2.EXE has stopped working". Now seeing as I'm running Windows 7 I can't get much info from this dialog box on what the exact cause of the problem is.

Now before you go and blame it on Windows 7 let me say that I had the same problem in Vista and to some extent in XP. I haven't any viruses and my computer is free of any and all malware. I have tried re-installing both Half-Life 2 and TF2 with no success. I am rather at a loss as to what to do at this point and would really like some insight into this problem. I also verified the integrity of the game cache or whatever through Steam and whatnot.

I would appreciate any help ya'll can offer.

Comments

  • Samm!!! avatar
    Samm!!! Offline
    Member Joined 8 years ago
    225 points Ranked 14803rd
    Report post
    8 years ago:
    Perhaps its your PC hardware,what've you got?
    'Sup
  • Apple3.14 avatar
    Apple3.14 Offline
    Member Joined 8 years ago
    462 points Ranked 8508th
    Report post
    8 years ago:
    CPU: Intel Core 2 Duo

    RAM: 4GB of DDR2SDRAM

    VC: nVidia GeForce 8600m GT w/ 512mb dedicated RAM

    Monitor: 15" Wide-screen, matte finish

    HDD: Inboard- Hitachi Travel Star 200GB @ 7200rpm Outboard- Western Digital Passport Identity 250GB USB 2.0
    BLAAAAAAAAAAAAGH!
  • Apple3.14 avatar
    Apple3.14 Offline
    Member Joined 8 years ago
    462 points Ranked 8508th
    Report post
    8 years ago:
    I figured out the issue...I think, I had my settings too high for high def skins. The game was working fine with only a few installed but with many it began to have troubles on some servers. I think that may be the problem.
    BLAAAAAAAAAAAAGH!
  • Joshh avatar
    Joshh Offline
    Member Joined 8 years ago
    1,512 points Ranked 2932nd
    Report post
    8 years ago:
    What DirectX version are you using? If it is 10, maybe try switiching down to 9. If it's 9, try switiching down to 8. Yeah, the graphics will be bad, but it might fix the problem.
    Help me get the most poll vote avatar
    Mantra
    Help me get the most poll vote
  • Apple3.14 avatar
    Apple3.14 Offline
    Member Joined 8 years ago
    462 points Ranked 8508th
    Report post
    8 years ago:
    Posted by Joshh

    What DirectX version are you using? If it is 10, maybe try switiching down to 9. If it's 9, try switiching down to 8. Yeah, the graphics will be bad, but it might fix the problem.


    I'm not sure what version I have...whatever it is it's the version that comes default with the Windows 7 RC. Which is probably 10 or 9.
    BLAAAAAAAAAAAAGH!
  • BrainZ avatar
    BrainZ avatar Offline
    Member Joined 9 years ago
    22,548 points Ranked 192nd
    Report post
    8 years ago:
    Posted by Joshh

    What DirectX version are you using? If it is 10, maybe try switiching down to 9. If it's 9, try switiching down to 8. Yeah, the graphics will be bad, but it might fix the problem.

    Can TF2 run on DX10? I don't think so.
    gone
  • Matuka avatar
    Matuka avatar Offline
    Member Joined 8 years ago
    1,822 points Ranked 2440th
    Report post
    8 years ago:
    Posted by BrainZ

    Posted by Joshh

    What DirectX version are you using? If it is 10, maybe try switiching down to 9. If it's 9, try switiching down to 8. Yeah, the graphics will be bad, but it might fix the problem.

    Can TF2 run on DX10? I don't think so.

    I was running TF2 on DX10, so i think so... Unless you mean "-dxlevel 10 -Novid" in the start-up settings...
    8)))))))))

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

Apple3.14 avatar
Apple3.14 Offline
Member Joined 8 years ago
462 points Ranked 8508th

Apple3.14
Send a Private Message to the submitter

Category

Stats

Posts
7
Views
3,960
Date Added
8 years ago
Jun 6 2009 @ 1:00pm UTC
Date Updated
8 years ago
Jun 6 2009 @ 1:00pm UTC