Crysis not running properly anymore?!

SEX! Ok, we got your attention. We are one of the oldest mod sites on the Interwebs. Sign up and maximize your browsing experience.

  • Subscribe: Get notified of new submissions like this.
  • Say Thanks: Show your appreciation by sending silent_disaster points.
  • Post: Give silent_disaster your thoughts on this Thread.
  • Flag: Alert moderators and warn members of a problem with this Thread.
  • Watch: Get notified when this Thread is updated.
Mascot

Sound fun?

Join GameBanana

Already a Bananite? Login

So my computer specs are pretty crap. I have Windows Vista 32-bit 2 gb of RAM AMD Athlon 64 X2 Dual Processor 5000+ 2.60GHz and an XFX Geforce 8600 GT 256mb (Crap much?) But anyways. I am able to run Crysis just past the minimum specs. I run Crysis on my computer at medium settings. But recently, something has been messing up with Crysis. I get sound lag, which causes graphic lag in turn. I restarted it many times and the problem still exists. It seems that it works properly once ever so often now, like maybe once every 3-4 days. Its really annoying. I've updated my drivers for whatever I have drivers for. No help. Can anyone else help figure out a diagnosis? Thank you in advance.

Posts

  • 9y
    (Empa) avatar
    (Empa) Offline
    Member Joined 9y
    181 points Ranked 18789th
    Virus? If it is a virus, then it would most likely be a worm. In that case you should scan it.
    BUCKETHEAD IS GOD.
  • 9y
    silent_disaster avatar
    Member Joined 10y
    Posted by (Empa)

    Virus? If it is a virus, then it would most likely be a worm. In that case you should scan it.


    It appears I do not have any viruses.
    Bananite
  • 9y
    (Empa) avatar
    (Empa) Offline
    Member Joined 9y
    181 points Ranked 18789th
    Posted by silent_disaster

    Posted by (Empa)

    Virus? If it is a virus, then it would most likely be a worm. In that case you should scan it.


    It appears I do not have any viruses.

    Power shortage? That would mean your power supply cant cope with your computer.
    BUCKETHEAD IS GOD.
  • 9y
    silent_disaster avatar
    Member Joined 10y
    Posted by (Empa)

    Posted by silent_disaster

    Posted by (Empa)

    Virus? If it is a virus, then it would most likely be a worm. In that case you should scan it.


    It appears I do not have any viruses.

    Power shortage? That would mean your power supply cant cope with your computer.

    I have no idea. There doesn't seem to be anything wrong with my power supply.
    BTW how do I check my power supply because I have no idea on how to find out what kind I have.
    Bananite
  • 9y
    DeadEcho avatar
    DeadEcho Offline
    Member Joined 10y
    396 points Ranked 10449th
    To check your power supply you need to open your case and look for the sticker on the side of the PSU. In regards to your problem, I had a similar problem as you. It was a problem with my sound drivers. So I would suggest try to update your sound drivers again.
    The echo is dead avatar
    Mantra
    The echo is dead
  • 9y
    ninjaz1337 avatar
    ninjaz1337 Offline
    Member Joined 10y
    445 points Ranked 9541st
    Maybe you're computer is overheated?
    Wait, what do I put here again
  • 9y
    Job_For_A_Cowboy avatar
    Member Joined 11y
    13,297 points Ranked 324th
    Re-intall crysis
    Chicken and Broccoli avatar
    Mantra
    Chicken and Broccoli
  • 9y
    TheGrymoire avatar
    Member Joined 10y
    5,787 points Ranked 774th
    Install "EVGA Precision and monitor your temperatures in game. My 8600 used to overheat.
    Fractals in Nature avatar
    Mantra
    Fractals in Nature
  • 9y
    Ajax NV avatar
    Ajax NV Offline
    Member Joined 10y
    Could be simply you have too many background programs running.
    Nosce te ipsum
  • 9y
    JPC avatar
    JPC Offline
    Member Joined 9y
    4,155 points Ranked 1095th
    12 medals 2 rare
    • 25 posts awarded Exemplary Feedback Medal icon
    • 6 years a member Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • 5 posts awarded Exemplary Feedback Medal icon
    Did you get all the patches for Crysis or are you still trying out the original?
    "War were declared."
  • 9y
    silent_disaster avatar
    Member Joined 10y
    Posted by Thomas

    Is it your soundcard?


    Not sure. Im using the default one that was installed in the computer when i got it.
    Bananite
  • 9y
    silent_disaster avatar
    Member Joined 10y
    Posted by JPC

    Did you get all the patches for Crysis or are you still trying out the original?

    I got all the patches a few weeks ago.
    Bananite
  • 9y
    JPC avatar
    JPC Offline
    Member Joined 9y
    4,155 points Ranked 1095th
    12 medals 2 rare
    • 25 posts awarded Exemplary Feedback Medal icon
    • 6 years a member Medal icon
    • Reached 1,000 Points Medal icon
    • Reached 2,500 Points Medal icon
    • 1 post awarded Exemplary Feedback Medal icon
    • 5 posts awarded Exemplary Feedback Medal icon
    Ok if that's not the issue, it has to be something else. Don't know what, but it could be a engine error or maybe a sound error. I've never heard of this happening before, and if you think your graphics card is crap I have a 6200 Nvidia GeForce card. So heh, I was able to play to the second area of the island.
    "War were declared."
  • 9y
    silent_disaster avatar
    Member Joined 10y
    Problem solved.
    I remembered that i switched the sound quality from CD format to Studio Format a long time ago.
    That fixed it.
    Thanks, to those who tried to help.
    Bananite

Share

Shareable Image:
Share banner
HTML embed code:
BB embed code:
Markdown embed code:

More embeddable images

Bookmark and Share

Submitter

Send a Private Message to the submitter

Game

Category

Stats

Posts
14
Views
2,437
Date Added
9y
bcp.crwdcntrl.net tracking pixel